2013 Asia Hangzhou Regional Contest bnuoj ID: 4771

B. Stealing Harry Potter's Precious

Time Limit: 1000ms
Memory Limit: 32768KB
64-bit integer IO format:  %I64d      Java class name:  Main
  Harry Potter has some precious. For example, his invisible robe, his wand and his owl. When Hogwarts school is in holiday, Harry Potter has to go back to uncle Vernon's home. But he can't bring his precious with him. As you know, uncle Vernon never allows such magic things in his house. So Harry has to deposit his precious in the Gringotts Wizarding Bank which is owned by some goblins. The bank can be considered as a N × M grid consisting of N × M rooms. Each room has a coordinate. The coordinates of the upper-left room is (1,1) , the down-right room is (N,M) and the room below the upper-left room is (2,1)..... A 3×4 bank grid is shown below:



  Some rooms are indestructible and some rooms are vulnerable. Goblins always care more about their own safety than their customers' properties, so they live in the indestructible rooms and put customers' properties in vulnerable rooms. Harry Potter's precious are also put in some vulnerable rooms. Dudely wants to steal Harry's things this holiday. He gets the most advanced drilling machine from his father, uncle Vernon, and drills into the bank. But he can only pass though the vulnerable rooms. He can't access the indestructible rooms. He starts from a certain vulnerable room, and then moves in four directions: north, east, south and west. Dudely knows where Harry's precious are. He wants to collect all Harry's precious by as less steps as possible. Moving from one room to another adjacent room is called a 'step'. Dudely doesn't want to get out of the bank before he collects all Harry's things. Dudely is stupid.He pay you $1,000,000 to figure out at least how many steps he must take to get all Harry's precious.

Input

  There are several test cases.
  In each test cases:
  The first line are two integers N and M, meaning that the bank is a N × M grid(0<N,M <= 100).
  Then a N×M matrix follows. Each element is a letter standing for a room. '#' means a indestructible room, '.' means a vulnerable room, and the only '@' means the vulnerable room from which Dudely starts to move.
  The next line is an integer K ( 0 < K <= 4), indicating there are K Harry Potter's precious in the bank.
  In next K lines, each line describes the position of a Harry Potter's precious by two integers X and Y, meaning that there is a precious in room (X,Y).
  The input ends with N = 0 and M = 0

Output

  For each test case, print the minimum number of steps Dudely must take. If Dudely can't get all Harry's things, print -1.

Sample Input

2 3
##@
#.#
1
2 2
4 4
#@##
....
####
....
2
2 1
2 4
0 0

Sample Output

-1

5

这题广搜厉害了,本人智商低,无论如何也想不到大神一个广搜的方法,我组方法就是把所有经过点的顺序排列组合,代码超级长,上一大神代码

#include <iostream>
#include <cstdio>
#include <cstring>
#include <algorithm>
#include <cmath>
#include <queue>
using namespace std;
const int maxn=120;
bool vis[maxn][maxn][17];
char maze[maxn][maxn];// * baowu ;  # wall;  . empty; @ start;
int n,m,k;
int dir[4][2]={{0,1},{1,0},{-1,0},{0,-1}};


struct Node
{
    int x,y,step,bao;
};
bool inside(int x,int y)
{
    if(x>=0&&x<n&&y>=0&&y<m) return true;
    return false;
}
bool isbao(char s)
{
    if(s>='0'&&s<='9') return true;
    return false;
}
int bfs(int sx,int sy)
{
    queue<Node>Q;
    Node now,_next;
    now.x=sx,now.y=sy,now.step=0,now.bao=0;
    vis[sx][sy][0]=true;
    Q.push(now);
    while(Q.size())
    {
        now=Q.front();
        Q.pop();
      //  cout<<" i "<<now.x<<" "<<now.y<<" "<<now.step<<" "<<now.bao<<endl;
        if(now.bao==((1<<k)-1))
        {
          //  cout<<now.x<<" niu "<<now.y<<" "<<now.step<<endl;
            return now.step;
        }
        for(int i=0;i<4;i++)
        {
            int xx=now.x+dir[i][0],yy=now.y+dir[i][1];
            int bao=now.bao;
            if(inside(xx,yy)&&isbao(maze[xx][yy])) bao=bao|(1<<(maze[xx][yy]-'0'));
            if(inside(xx,yy)&&vis[xx][yy][bao]==false&&maze[xx][yy]!='#')
            {
                _next.step=now.step+1;
                _next.x=xx,_next.y=yy,_next.bao=bao;
                if(isbao(maze[xx][yy]))
                   {
                     //  cout<<_next.step<<"  step "<<_next.bao<<endl;
                   }
                vis[xx][yy][bao]=true;
                Q.push(_next);
            }
        }
    }
    return -1;
}

int main()
{
    while(scanf("%d%d",&n,&m)!=EOF)
    {
        if(n==0||m==0) return 0;
        memset(vis,0,sizeof(vis));
        int sx,sy;
        for(int i=0; i<n; i++)
        {
            scanf("%s",maze[i]);
            for(int j=0; j<m; j++)
                if(maze[i][j]=='@') sx=i,sy=j;
        }
        scanf("%d",&k);
        for(int i=0; i<k; i++)
        {
            int x,y;
            scanf("%d%d",&x,&y);
            maze[x-1][y-1]='0'+i;
        }
        printf("%d\n",bfs(sx,sy));
    }
    return 0;
}
/*
4 5
###@#
#....
###.#
###.#
3
2 2
2 3
3 4
*/

用1111代表找到了四个bao

1是编号为1的bao

10==2是编号为2的宝

100=4是编号为3的bao

抑或后就是找到了几个bao

找到一个包后,状态就变了,到用这个点搜的时候,就相当于以这个状态去搜了,以前走过的点还可以走,就用另一个vis[]标记


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值