linux离线安装grunt+ruby+compass

版权声明:本文为博主原创文章,未经博主允许不得转载。 https://blog.csdn.net/greenqingqingws/article/details/73889312

不要问为什么不能在线安装

由于众所周知的原因,公司测试服务器不能连外网,只能连内网~码农们需要一套测试环境来编译,只能自己动手丰衣足食。好心的服务器维护人员帮忙装好了nodejs,所以自己再安装好grunt、ruby、compass,就又可以愉快的玩耍了。

大boss-离线安装grunt

  1. github上下载grunt-cli的源码
  2. 找到/usr/local/bin,将grunt-cli/bin中的文件拷贝过去
  3. 找到/usr/local/lib,将grunt-cli/lib中的文件拷贝过去
  4. 找到/usr/local/,将grunt-cli/node_modules文件目录整个拷贝过去。node_modules文件目录是在/usr/local/目录下。
  5. 在命令行中输入
    grunt
    ,会看到
     
    grunt-cli: The grunt command line interface. (v0.1.13)
    Fatal error: Unable to find local grunt.
    If you're seeing this message,either a Gruntfile wasn't found or grunt hasn't been installed locally to your project. For more information about installing and configuring grunt,please see the Getting Started guide:
    http://gruntjs.com/getting-started
  6. 看到这段不用慌,说明全局grunt已经安装成功了,local grunt在项目的node-modules里面会带上的,所以不影响在项目中使用grunt build命令。

离线安装ruby

  1. 在命令行中输入
    ruby -v
  2. 发现服务器中没有ruby,内心是崩溃的。不过好在离线安装ruby比较容易,网上有很多集成了ruby的工具,我选择了装RVM。

  3. 离线安装RVM,这活就比较简单了。直接参考RVM in offline mode 中的步骤做就好了。

    • https://github.com/rvm/rvm/tarball/stable上下载文件
    • 创建目录,
      mkdir rvm
    • 进入目录,
      cd rvm
    • 将rvm的安装包解压到刚刚创建好的rvm目录中,
      tar --strip-components=1 -xzf ../rvm-stable.tar.gz
    • 安装rvm,
      ./install --auto-dotfiles
    • 加载rvm,
      source scripts/rvm
    • 在命令行中输入
      rvm -v
      ,就能看到如下
      rvm 1.29.1 (manual) by Michal Papis,... 
  4. 安装完RVM之后,在命令行中输入
    ruby -v
    ,发现ruby也有了~~完美
  5. 但是好景不长,在后面的安装过程中发现,rvm中自带的ruby由于版本比较低,无法满足后面项目中需要安装的compass的要求,所以又去努力搜索了一下离线安装ruby的方法,参考http://blog.csdn.net/lhf_tiger/article/details/8784530 文章中的方法,下载了ruby2.4.1的压缩包,重新安装了ruby。
    • 下载ruby-2.4.1.tar.gz压缩包
    • 解压安装文件,
      tar -xvf ruby-2.4.1.tar.gz
    • 进入文件夹,
      cd ruby-2.4.1
      ,随后进行安装三部曲
    • 配置,
      ./configure -prefix=/usr/local/ruby-1.9
    • 编译,
      make
    • 安装,
      make install 
    • 修改环境变量,参照在Linux里设置环境变量的方法(export PATH)
      ,就不在此介绍了

离线安装compass

  1. 为了安装compass,需要先安装gem,rubygems安装就比较简单了
  2. 参考rubygems官网上介绍,https://rubygems.org/pages/download ,先下载rubygems安装文件rubygems-2.4.6.tgz
  3. 解压之后,会有rubygems-2.4.6目录,进入这个目录。
  4. 执行命令,
    ruby setup.rb 
  5. 安装完成之后,输入命令,
    gem -v 
  6. 会看到如下信息,
    2.6.11
  7. 然后再去https://rubygems.org/gems/compass/versions/1.1.0.alpha.3 上面下载compass以及相关的依赖包gem文件,所有文件下载下来之后,新建一个文件目录gem,然后将所有gem文件放到这个目录下,
    mkdir gem
  8. 进入gem文件目录,
    cd gem
  9. 执行安装compass命令,我下载的compass安装文件为compass-1.0.3.gem,
    gem install --local compass-1.0.3.gem
  10. 如果安装不成功,应该是缺少依赖包,自己再去https://rubygems.org 上面下就可以了,安装成功之后,在命令中输入,
    compass -v
    ,会出现
    Compass 1.0.3(Polaris) ...
    ,看到这些信息,就说明已经安装成功了。

从此,又可以愉快的玩耍了

展开阅读全文

没有更多推荐了,返回首页