【HDU 5944】【暴力】Fxx and string 【给定一个字符串s,求有多少个三元组(i,j,k)满足i,j,k是等比数列且s[i]=='y'&&s[j]=='r'&&s[k]=='x'】

传送门:http://acm.split.hdu.edu.cn/showproblem.php?pid=5944

描述:

Fxx and string

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 131072/65536 K (Java/Others)
Total Submission(s): 103    Accepted Submission(s): 49


Problem Description
Young theoretical computer scientist Fxx get a string which contains lowercase letters only.

The string  S  contains  n  lowercase letters  S1S2Sn .Now Fxx wants to know how many three tuple  (i,j,k)  there are which can meet the following conditions:

1、 i,j,k  are adjacent into a geometric sequence.

2、 Si= ' y ' ,Sj= ' r ' ,Sk= ' x '.

3.Either j|i or j|k
 

Input
In the first line, there is an integer  T(1T100)  indicating the number of test cases.

T  lines follow, each line contains a string, which contains only lowercase letters.(The length of string will not exceed  10000 ).
 

Output
For each case, output the answer.
 

Sample Input
  
  
2 xyyrxx yyrrxxxxx
 

Sample Output
  
  
0 2
 

Source
 

Recommend
wange2014   |   We have carefully selected several similar problems for you:   5947  5946  5945  5943  5942 

题意:

给定一个字符串s,下标从1开始,求有多少个三元组(i,j,k)满足i,j,k是等比数列且s[i]=='y'&&s[j]=='r'&&s[k]=='x'


思路:

枚举i和等比数列公比q,但考虑到q有可能是1/t 的形式,所以倒过来枚举一遍就可以了。


代码:

#include <bits/stdc++.h>
using  namespace  std;
#define rrep(i,k,n) for(int i=k;i>=n;i--)

const int N=1e4+10;

char s[N];
int ans;

int  main(){
  int t;
  scanf("%d", &t);
  while(t--){
    scanf("%s", s + 1);
    ans = 0;
    int n = strlen(s + 1);
    rrep(i, n, 1){
      if(s[i] != 'r')continue;
      for(int q = 2; q <= i; q++){
        if(i * q > n)break;
        if(i % q) continue;
        if(s[i / q] == 'y' && s[i * q] == 'x' || s[i / q] == 'x' && s[i * q] == 'y')ans++;
      }
    }
    printf("%d\n", ans);
  }
  return 0;
}



  • 2
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值