An inch worm is at the bottom of a well n inches deep. It has enough energy to climb u inches every minute, but then has to rest a minute before climbing again. During the rest, it slips down d inches. The process of climbing and resting then repeats. How long before the worm climbs out of the well? We'll always count a portion of a minute as a whole minute and if the worm just reaches the top of the well at the end of its climbing, we'll assume the worm makes it out.
Input
There will be multiple problem instances. Each line will contain 3 positive integers n, u and d. These give the values mentioned in the paragraph above. Furthermore, you may assume d < u and n < 100. A value of n = 0 indicates end of output.
Output
Each input instance should generate a single integer on a line, indicating the number of minutes it takes for the worm to climb out of the well.
Sample Input
10 2 1
20 3 1
0 0 0
Sample Output
17
19
题目大意:一个高度为n的井,小虫每分钟爬u英尺,爬一分钟休息一分钟,休息的一分钟会滑落d。求爬完整个路程的时间。
思路,向上爬u,加一分钟,如果没有到顶(n>0),再加一分钟(休息),而且整个路程也会延长d滑落的长度。
1,代码实现
#include<stdio.h>
int main()
{ /*a为总路程,b为每次爬的长度,c为滑落的长度,t为所需要的总时间。*/
int a =0, b=0 ,c=0 ,t=0;
while(scanf("%d %d %d" ,&a,&b,&c)!=EOF)
{
if(a==0&&b==0&&c==0) break;
while(1)
{
a= a-b;
t++;
if(a>0)
{ a= a+c;
t++;
}
else break;
}
printf("%d" ,t);
t=0;
printf("\n");
}
}