An internal error occurred during: "JSP Semantics Validator (JSF)". org/eclipse/

An internal error occurred during: "JSP Semantics Validator (JSF)".
org/eclipse/wst/sse/ui/internal/reconcile/validator/ValidationHelper

 

这个问题的解决方法:这是由于插件org.eclipse.wst.sse.ui所致,myeclipse中的这个插件是修改过的zmyeclipse版本(在 myeclipse安装目录/eclipse/plugins中),但之后自动升级功能下载了更新版本的未修改版插件(在原eclipse的plugin 中),所以myeclipse据版本号判断加载了更新的插件。
但myeclipse的运行依赖修改版本的插件添加的一些功能,可是新的插件未包含这些功能。

如错误中出现的org/eclipse/wst/sse/ui/internal/reconcile/validator /ValidationHelper.class,其实在未修改版本中根本不存在这个类,所以出错。
解决方案:将原eclipse中plugins中的org.eclipse.wst.sse.ui_1.x.xxxxxxx.jar挪到其他地方。

展开阅读全文

没有更多推荐了,返回首页