HDU 4324 Triangle LOVE

Triangle LOVE

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/65536 K (Java/Others)
Total Submission(s): 3542    Accepted Submission(s): 1381


Problem Description
Recently, scientists find that there is love between any of two people. For example, between A and B, if A don’t love B, then B must love A, vice versa. And there is no possibility that two people love each other, what a crazy world!
Now, scientists want to know whether or not there is a “Triangle Love” among N people. “Triangle Love” means that among any three people (A,B and C) , A loves B, B loves C and C loves A.
  Your problem is writing a program to read the relationship among N people firstly, and return whether or not there is a “Triangle Love”.
 

Input
The first line contains a single integer t (1 <= t <= 15), the number of test cases.
For each case, the first line contains one integer N (0 < N <= 2000).
In the next N lines contain the adjacency matrix A of the relationship (without spaces). A i,j = 1 means i-th people loves j-th people, otherwise A i,j = 0.
It is guaranteed that the given relationship is a tournament, that is, A i,i= 0, A i,j ≠ A j,i(1<=i, j<=n,i≠j).
 

Output
For each case, output the case number as shown and then print “Yes”, if there is a “Triangle Love” among these N people, otherwise print “No”.
Take the sample output for more details.
 

Sample Input
  
  
2 5 00100 10000 01001 11101 11000 5 01111 00000 01000 01100 01110
 

Sample Output
  
  
Case #1: Yes Case #2: No
 

Author
BJTU
 

Source
 

Recommend
zhoujiaqi2010   |   We have carefully selected several similar problems for you:   1068  4320  4325  3309  3712
//这道题就是用拓扑的方法来判断是否成环,我的做法就是看是否能够排成有序的序列,参考代码如下:
 
 
#include<stdio.h>
#include<string.h>
int indegree[10010];
char mp[10010][10010];
int main()
{  int  k=1;
   int  flag;
   int  t,n;
   scanf("%d",&t);
   while(t--)
    {    int i,j;
         //int m;
    	 scanf("%d",&n);
    	 memset(indegree,0,sizeof(indegree));
		 flag=0;
		 for(i=0;i<n;i++)
		 {
		    scanf("%s",mp[i]);
		    for(j=0;j<n;j++)
		    if(mp[i][j]=='1')
			indegree[j]++;  
		 } 
		 //int  m;
		 for(j=0;j<n;j++)
		  {
		  	 for(i=0;i<n;i++)
		  	     if(indegree[i]==0)
					   break; 
		  	         
		  	if(i==n)
		  	 {
			     flag=1;
		  	     break;
		  	 }
		  	else
		  	    {
		  	       indegree[i]=-1;
				   for(int k=0;k<n;k++)
				     {
				     	if(mp[i][k]=='1'&&indegree[k]!=0)
				     	  indegree[k]--;
				     }		
		  	    }
		  }   
		  if(flag)
		  printf("Case #%d: Yes\n",k++);
		  else
		  printf("Case #%d: No\n",k++);	
    }
	return 0;	
}

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值