增加PHP版本并切换PHP版本

目录

 

一、增加PHP版本

二、切换PHP版本


一、增加PHP版本

1、已经安装了WampServer(32位),我的PHP目录是A:\WampServer\wamp\bin\php\php5.4.3,即默认安装的PHP版本是5.4.3。

有些项目需要的PHP版本不同,所以要在wamp\bin\php目录下添加多个PHP版本。

之前试过装成功了PHP7.2.8版本,第一次装了64位的PHP没成功,删除了重装32位的PHP就成功了。

现在做项目遇到个错误信息“count():Parameter must be an array or an object that implements Countable”,需要降低PHP版本,所以现在再装个PHP7.1版本。

这里,增加PHP版本教程有这两个就够了:《在WAMPSERVER下增加多版本的PHP(PHP5.3,PHP5.4,PHP5.5)支持。》 和《如何升级php版本---从php5.5.12 升级php7.1.5 wamp实践》。

2、在https://windows.php.net/download/ 下载所需要的PHP版本“*** x86 Thread Safe”,比如我下载的是PHP7.1.21版本的Zip包,放到PHP目录下,如我的目录A:\WampServer\wamp\bin\php,解压并重命名文件夹“php7.1.21”,即“PHP版本号”。

想了解不同下载版本的可以去看《windows下php的版本如何选择?》。

3、将已有版本的php文件夹(比如PHP5.4.3文件夹)中的php.iniphpForApache.iniwampserver.conf 文件复制到 php7.1.21文件夹中。

4、修改php.ini、phpForApache.ini 两个文件,查找两个文件中所有的php5.4.3并替换成php7.1.21。

5、修改wampserver.conf文件, 参考如何升级php版本---从php5.5.12 升级php7.1.5 wamp实践》第6步。

我从wamp\bin\apache目录下发现“apache2.2.22”文件夹,所以我的apache版本是2.2X,那么wampserver.conf文件中的修改如下:

$phpConf['apache']['2.2']['LoadModuleName'] = 'php7_module';
$phpConf['apache']['2.2']['LoadModuleFile'] = 'php7apache2_2.dll';

6、在 wamp\bin\apache\apache2.2.22\bin 目录下,将php.ini 文件删除。

7、在wamp\bin\apache\apache2.2.22\conf 目录下,找到httpd.conf 文件,查找LoadModule,将其改为

LoadModule php7_module "A:/WampServer/wamp/bin/php/php7.1.21/php7apache2_2.dll"

8、在wamp\bin\php\php7.1.21文件夹中,新建一个文件夹并命名为“zend_ext”。

https://xdebug.org/download.php 中下载对应的动态链接库 到 zend_ext 文件夹,我这里版本是7.1,Thread Safe(线程安全),32位的。这个 动态链接库 名字为“php_xdebug-2.7.0alpha1-7.1-vc14.dll”。

9、在 wamp\bin\php\php7.1.21文件夹中,找到 php.ini 文件,修改如下:

; XDEBUG Extension

zend_extension = "A:/WampServer/wamp/bin/php/php7.1.21/zend_ext/php_xdebug-2.7.0alpha1-7.1-vc14.dll"

10、最后,在php.ini 文件中 注释掉 这句

;extension=php_mysql.dll

11、 重启WampServer。

左键点击WampServer图标,选择“PHP”,好奇点开“php.ini”文件(这个文件其实在wamp\bin\apache\apache2.2.22\bin文件夹里,之前的步骤6有删除过一次,这里应该是又自动生成了)。

又好奇就把“php.ini”文件里的 “php版本号” 改成 “php7.1.21” ,动态链接库也按步骤9改了。

extension_dir = "A:/WampServer/wamp/bin/php/php7.1.21/ext/"
; XDEBUG Extension

zend_extension = "A:/WampServer/wamp/bin/php/php7.1.21/zend_ext/php_xdebug-2.7.0alpha1-7.1-vc14.dll"

12、装好之后多点开几次WampServer(一开始没有看到php7.1.21版本,我就多点了几次),PHP→Version出现了“7.1.21”,至此增加php版本成功。

但是PHP→Version前面的“√”还是打在“7.2.8”前面,于是我在命令提示符窗口cmd输入

php -v

发现当前使用的php版本没变,依然是“php7.2.8”,下面进行PHP版本切换。

二、切换PHP版本

Windows下设置PHP的环境变量就行了,参考教程《windows下设置PHP环境变量》。

1、Win10下,右击“此电脑”→“属性”→“高级系统设置”→“环境变量”,在“系统变量”里找到“Path”,双击编辑。

2、找到php的路径,把最后的路径“php7.2.8”改成你要的版本,这里改成“wamp\bin\php\php7.1.21”。

3、在命令提示符窗口cmd输入

php -v

  

可以看到,php的版本已经切换成功了。

 

 

  • 1
    点赞
  • 7
    收藏
  • 打赏
    打赏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
©️2022 CSDN 皮肤主题:创作都市 设计师:CSDN官方博客 返回首页
评论

打赏作者

haisley

你的鼓励将是我创作的最大动力

¥2 ¥4 ¥6 ¥10 ¥20
输入1-500的整数
余额支付 (余额:-- )
扫码支付
扫码支付:¥2
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、C币套餐、付费专栏及课程。

余额充值