整理音乐

Problem Description


请用链表完成下面题目要求。
xiaobai 很喜欢音乐,几年来一直在收集好听的专辑。他有个习惯,每次在听完一首音乐后会给这首音乐打分,而且会隔一段时间给打好分的音乐排一个名次。今天 xiaobai 打开自己的音乐文件夹,发现有很多不同时期打过分的排好序的子音乐文件夹,他想把这些音乐放到一块,组成一个分数有序的序列。由于音乐文件很多,而文件里音乐的数目也是不确定的,怎么帮帮 xiaobai 完成这件工作呢?
   

Input

输入数据第一行为一个整数n(n<1000),代表文件夹的数量。接下来是n个文件夹的信息,每个文件夹信息的第一行是一个数字m(m<=10000),代表这个文件夹里有m首歌,后面m行每行一个歌曲名、分数,之间用空格分开。歌曲名称不超过5个字符。

Output

输出一行,为所有音乐组成的一个序列,音乐只输出名字。

如果音乐分数相同则按照音乐名字典序进行排序。

Example Input
3
4
aaa 60
aab 50
aac 40
aad 30
2
kkk 60
kkd 59
3
qow 70
qwe 60
qqw 20
Example Output
qow aaa kkk qwe kkd aab aac aad qqw



#include <stdio.h>
#include <stdlib.h>
struct node
{
    int sc;
    char name[6];
    struct node *next;
}*head,*head1,*tail,*p,*q;
void print(struct node *head)
{
    p=head->next;
    while(p!=NULL)
    {
        if(p->next==NULL)
            printf("%s\n",p->name);
        else
            printf("%s ",p->name);
        p=p->next;
    }
}
struct node *create(int x)
{
    int i;
    head=(struct node *)malloc(sizeof(struct node));
    head->next=NULL;
    tail=head;
    for(i=1;i<=x;i++)
       {
        p=(struct node *)malloc(sizeof(struct node));
        p->next=NULL;
       scanf("%s %d",p->name,&p->sc);
       tail->next=p;
       tail=p;
       tail->next=NULL;
       }
       return head;
};
struct node *merge(struct node *head,struct node *head1)
{
    p=head->next;
    q=head1->next;
    head->next=NULL;
    free(head1);
    tail=head;
    while(q&&p)
    {
        if(p->sc>=q->sc)
        {
            tail->next=p;
            tail=p;
            p=p->next;
            tail->next=NULL;
        }
        else
        {
            tail->next=q;
            tail=q;
            q=q->next;
            tail->next=NULL;
        }
    }
    while(p)
    {
            tail->next=p;
            tail=p;
            p=p->next;
            tail->next=NULL;
    }
    while(q)
    {
            tail->next=q;
            tail=q;
            q=q->next;
            tail->next=NULL;
    }
      return head;
};
int main()
{
    int n,m,i,j;
    struct node *h;
    struct node *y,*w;
    scanf("%d",&n);
    scanf("%d",&m);
    y=create(m);
    for(i=2;i<=n;i++)
    {
        scanf("%d",&m);
        h=create(m);
        w=merge(y,h);
        y=w;
    }
    print(y);
    return 0;
}
 
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值