LCIS

Problem Description

Alex has two sequences a_1,a_2,...,a_na1,a2,...,an and b_1,b_2,...,b_mb1,b2,...,bm. He wants find a longest common subsequence that consists of consecutive values in increasing order.

Input

There are multiple test cases. The first line of input contains an integer TT, indicating the number of test cases. For each test case:

The first line contains two integers nn and mm (1 \le n, m \le 100000)(1n,m100000) -- the length of two sequences. The second line contains nn integers: a_1, a_2, ..., a_na1,a2,...,an (1 \le a_i \le 10^6)(1ai106). The third line contains nn integers: b_1, b_2, ..., b_mb1,b2,...,bm (1 \le b_i \le 10^6)(1bi106).

There are at most 10001000 test cases and the sum of nn and mm does not exceed 2 \times 10^62×106.

Output

For each test case, output the length of longest common subsequence that consists of consecutive values in increasing order.

Sample Input
3
3 3
1 2 3
3 2 1
10 5
1 23 2 32 4 3 4 5 6 1
1 2 3 4 5
1 1
2
1
Sample Output
1
5
0
 
  
 
  
 
  
 
  
 
  
 
  
#include<iostream>
#include<cstring>
using namespace std;
const int maxn=100000+10;
int main()
{
    int t;
    int maxlen[maxn];
    int a[maxn],b[maxn];
    cin>>t;
    int n,m;
    while(t--)
    {
        memset(maxlen,0,sizeof(maxlen));
        cin>>n>>m;
        for(int i=1;i<=n;i++)
            cin>>a[i];
        for(int i=1;i<=m;i++)
            cin>>b[i];
            for(int i=1;i<=n;i++)
                for(int j=1,temp=0;j<=m;j++)
            {
                if(a[i]>b[j]&&maxlen[j]>temp)
                    temp=maxlen[j];
                else if(a[i]==b[j])
                    maxlen[j]=temp+1;
            }
            int max=0;
            for(int i=1;i<=m;i++)
                if(max<maxlen[i])
                max=maxlen[i];
            cout<<max<<endl;
    }
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值