ACM Computer Factory poj 3436 增广流

ACM Computer Factory
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 7289 Accepted: 2595 Special Judge

Description

As you know, all the computers used for ACM contests must be identical, so the participants compete on equal terms. That is why all these computers are historically produced at the same factory.

Every ACM computer consists of P parts. When all these parts are present, the computer is ready and can be shipped to one of the numerous ACM contests.

Computer manufacturing is fully automated by using N various machines. Each machine removes some parts from a half-finished computer and adds some new parts (removing of parts is sometimes necessary as the parts cannot be added to a computer in arbitrary order). Each machine is described by its performance (measured in computers per hour), input and output specification.

Input specification describes which parts must be present in a half-finished computer for the machine to be able to operate on it. The specification is a set of P numbers 0, 1 or 2 (one number for each part), where 0 means that corresponding part must not be present, 1 — the part is required, 2 — presence of the part doesn't matter.

Output specification describes the result of the operation, and is a set of P numbers 0 or 1, where 0 means that the part is absent, 1 — the part is present.

The machines are connected by very fast production lines so that delivery time is negligibly small compared to production time.

After many years of operation the overall performance of the ACM Computer Factory became insufficient for satisfying the growing contest needs. That is why ACM directorate decided to upgrade the factory.

As different machines were installed in different time periods, they were often not optimally connected to the existing factory machines. It was noted that the easiest way to upgrade the factory is to rearrange production lines. ACM directorate decided to entrust you with solving this problem.

Input

Input file contains integers P N, then N descriptions of the machines. The description of ith machine is represented as by 2 P + 1 integers Qi Si,1 Si,2...Si,PDi,1 Di,2...Di,P, where Qi specifies performance, Si,j — input specification for part jDi,k — output specification for part k.

Constraints

1 ≤ P ≤ 10, 1 ≤ ≤ 50, 1 ≤ Qi ≤ 10000

Output

Output the maximum possible overall performance, then M — number of connections that must be made, then M descriptions of the connections. Each connection between machines A and B must be described by three positive numbers A B W, where W is the number of computers delivered from A to B per hour.

If several solutions exist, output any of them.

Sample Input

Sample input 1
3 4
15  0 0 0  0 1 0
10  0 0 0  0 1 1
30  0 1 2  1 1 1
3   0 2 1  1 1 1
Sample input 2
3 5
5   0 0 0  0 1 0
100 0 1 0  1 0 1
3   0 1 0  1 1 0
1   1 0 1  1 1 0
300 1 1 2  1 1 1
Sample input 3
2 2
100  0 0  1 0
200  0 1  1 1

Sample Output

Sample output 1
25 2
1 3 15
2 3 10
Sample output 2
4 5
1 3 3
3 5 3
1 2 1
2 4 1
4 5 1
Sample output 3
0 0

Hint




#include<cstdio>
#include<cstring>
#include<iostream>
#include<queue>
#include<algorithm>
using namespace std;


const int M=500;  //最大点数  
const int inf=1e9;//流无限值  
int g[M][M],np,p[M];//  g图的邻接表,np点数,p前驱结点数组 
int ekst,eked;//源与汇 


int EK_bfs()
{
   queue<int>q;
   int f[M];
   memset(f,0,sizeof(f));
   memset(p,-1,sizeof(p));
   q.push(ekst);
   f[ekst]=1;
   while(!q.empty())
   {
     int e=q.front();
     if(e==eked) //找到增广路  
     return 1;
     q.pop();
     for(int i=1;i<=np;i++)
     {
       if(g[e][i]&&!f[i])
       {
        f[i]=1;
        p[i]=e;
        q.push(i);
       }
     }
   }
   return 0;
}


int EKA()//Edmond_Karp_Algorithm  
                    //会改图,最终剩下流量残图  
{
   int u,mf=0,mn;
   while(EK_bfs())
   {
     mn=inf;
     u=eked;
     while(p[u]!=-1)//找瓶颈流量  
     {
       mn=min(mn,g[p[u]][u]);
       u=p[u];
     }
     mf+=mn;
     u=eked;
     while(p[u]!=-1)
     {
       g[p[u]][u]-=mn;//删去瓶颈流量  
       g[u][p[u]]+=mn;//建立反向边 
       u=p[u];
     }
   }
   return mf;
}


const int MP=12;
const int MN=55;
int mi[MN][MP],mo[MN][MP];//     进入与产出  
int gg[M][M];
const int MQ=1e5;//可能的最大边数  
int ans[MQ][3];


int main()
{
  int NP,N;
  scanf("%d%d",&NP,&N);
  ekst=0,eked=2*N+1,np=2*N+1;
  for(int i=1;i<=N;i++)
  {
     int nn;
     scanf("%d",&nn);
     gg[i][i+N]=g[i][i+N]=nn;
     int f=1;
     for(int j=1;j<=NP;j++)
     {
      scanf("%d",&mi[i][j]);
      if(mi[i][j]==1)
      f=0;
     }
     if(f)//寻找可以制作空板的机器  
     gg[0][i]=g[0][i]=inf;
     f=1;
     for(int j=1;j<=NP;j++)
     {
      scanf("%d",&mo[i][j]);
      if(mo[i][j]!=1)
      f=0;
     }
     if(f)//寻找可以出成品的机器  
     gg[i+N][eked]=g[i+N][eked]=inf;
  }
  for(int i=1;i<=N;i++)
  for(int j=1;j<=N;j++)
  {
    if(j==i)
    continue;
    int f=1;
    for(int k=1;k<=NP;k++)
    {
       if(mo[i][k]==1&&mi[j][k]==0)
       f=0;
       if(mo[i][k]==0&&mi[j][k]==1)
       f=0;
    }
    if(f)
    gg[i+N][j]=g[i+N][j]=inf;
  }
  printf("%d ",EKA());
  int an=0;
  for(int i=1;i<=N;i++)
  for(int j=1;j<=N;j++)
  {
    if(gg[i+N][j]-g[i+N][j]>0)
    {
     ans[an][0]=i;
     ans[an][1]=j;
     ans[an++][2]=gg[i+N][j]-g[i+N][j];
     }
  }
  printf("%d\n",an);
  for(int i=0;i<an;i++)
  printf("%d %d %d\n",ans[i][0],ans[i][1],ans[i][2]);
  return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值