Fence Repair (优先队列)——哈弗曼树

Farmer John wants to repair a small length of the fence around the pasture. He measures the fence and finds that he needs N (1 ≤ N ≤ 20,000) planks of wood, each having some integer length Li (1 ≤ Li ≤ 50,000) units. He then purchases a single long board just long enough to saw into the N planks (i.e., whose length is the sum of the lengths Li). FJ is ignoring the "kerf", the extra length lost to sawdust when a sawcut is made; you should ignore it, too.

FJ sadly realizes that he doesn't own a saw with which to cut the wood, so he mosies over to Farmer Don's Farm with this long board and politely asks if he may borrow a saw.

Farmer Don, a closet capitalist, doesn't lend FJ a saw but instead offers to charge Farmer John for each of the N-1 cuts in the plank. The charge to cut a piece of wood is exactly equal to its length. Cutting a plank of length 21 costs 21 cents.

Farmer Don then lets Farmer John decide the order and locations to cut the plank. Help Farmer John determine the minimum amount of money he can spend to create the N planks. FJ knows that he can cut the board in various different orders which will result in different charges since the resulting intermediate planks are of different lengths.

Input

Line 1: One integer N, the number of planks 
Lines 2.. N+1: Each line contains a single integer describing the length of a needed plank

Output

Line 1: One integer: the minimum amount of money he must spend to make N-1 cuts

Sample Input

3
8
5
8

Sample Output

34

Hint

He wants to cut a board of length 21 into pieces of lengths 8, 5, and 8. 
The original board measures 8+5+8=21. The first cut will cost 21, and should be used to cut the board into pieces measuring 13 and 8. The second cut will cost 13, and should be used to cut the 13 into 8 and 5. This would cost 21+13=34. If the 21 was cut into 16 and 5 instead, the second cut would cost 16 for a total of 37 (which is more than 34).

题意:

有一位农夫要把一个木板(长度为 N 块木板长度之和)使用 (N-1) 次锯成 N 块给定长度的小木板,每次锯都要收取一定费用,

这个费用就是当前锯的这个木板的长度,

给定各个要求的小木板的长度,及小木板的个数  N,求最小的费用;

 

PS:

3

8 5 8为例:

先锯长度为 21 的木板使其为 13 和 8 的两块木板,花费 21

再从长度为 13 的木板上锯下长度为 8 和 5 的两块木板,花费 13

总花费 : 21 + 13 = 34

如果第一次锯下 16 和 5,第二次锯下 8 和 8 ,总花费:21 + 16 = 37

思路:

要使总费用最小,那么每次只选取最小长度的两块木板相加,再把这些“和”累加到总费用中即可;

AC码:

/*******************************************************************
*考察哈弗曼树的运用,每次取得最小的两个组合,从集合中删除这两个权值
*并获得他们的权值和,一直重复直到只剩下一个权值
*一般使用优先队列实现 
*******************************************************************/
#include <iostream>
#include <queue>
#define ll long long
using namespace std;

priority_queue< ll,vector<ll>,greater<ll> > q;//优先队列 
//从小到大 
int main(){
	int n;
	ll ans,sum;
	while( cin >> n ){
		while( n-- ){
			cin >> sum;
			q.push(sum);
		}
		ans = 0;
		while( !q.empty() ){//q不为空
			sum = q.top();
			q.pop();
			sum += q.top();
			q.pop();
			ans += sum;
			q.push(sum);
		}
		cout << ans << endl;
		q.pop();
	}
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值