zoj2736简单题


点击打开链接

The daffodil number is one of the famous interesting numbers in the mathematical world. A daffodil number is a three-digit number whose value is equal to the sum of cubes of each digit.

For example. 153 is a daffodil as 153 = 13 + 53 + 33.

水仙花数字是数学世界中着名的有趣数字之一。 水仙花号码是一个三位数字,其数值等于每个数字的立方体总数。


例如。 153是黄水仙153 = 13 + 53 + 33。

Input

There are several test cases in the input, each case contains a three-digit number.

输入中有多个测试用例,每个用例都包含一个三位数字。

Output

One line for each case. if the given number is a daffodil number, then output "Yes", otherwise "No".

每种情况一行。 如果给定的编号是水仙花编号,则输出“是”,否则输出“否”。

Sample Input

153
610

Sample Output

Yes
No



#include<cstdio>
int main()
{
	int a,b,c,m,n;
	while(scanf("%d",&m)!=EOF)
	{
		a=m/100;
		b=m%100/10;
		c=m%10;
	//	printf("%d %d %d",a,b,c);
		if(m==a*a*a+b*b*b+c*c*c)
			printf("Yes\n");
		else
			printf("No\n");
	}
	return 0;
}

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值