1003 Emergency (25分)

As an emergency rescue team leader of a city, you are given a special map of your country. The map shows several scattered cities connected by some roads. Amount of rescue teams in each city and the length of each road between any pair of cities are marked on the map. When there is an emergency call to you from some other city, your job is to lead your men to the place as quickly as possible, and at the mean time, call up as many hands on the way as possible.

Input Specification:

Each input file contains one test case. For each test case, the first line contains 4 positive integers: N (≤500) - the number of cities (and the cities are numbered from 0 to N−1), M - the number of roads, C​1​​ and C​2​​ - the cities that you are currently in and that you must save, respectively. The next line contains N integers, where the i-th integer is the number of rescue teams in the i-th city. Then M lines follow, each describes a road with three integers c​1​​, c​2​​ and L, which are the pair of cities connected by a road and the length of that road, respectively. It is guaranteed that there exists at least one path from C​1​​ to C​2​​.

Output Specification:

For each test case, print in one line two numbers: the number of different shortest paths between C​1​​ and C​2​​, and the maximum amount of rescue teams you can possibly gather. All the numbers in a line must be separated by exactly one space, and there is no extra space allowed at the end of a line.

Sample Input:

5 6 0 2
1 2 1 5 3
0 1 1
0 2 2
0 3 1
1 2 1
2 4 1
3 4 1

Sample Output:

2 4

题解:

这道题目大概的意思就是给定一张图,图上不仅边有权值,而且结点还有权值,最后要求你计算从st到ed的最短路径的数量,并且输出这些最短路径经过结点的最大点权和。

大题的思路就是迪杰斯特拉算法,不过我们需要额外计算两个变量,分别是数组num和数组w。其实num[u]表示从st到u的最短路径的数量,w[u]表示从st到u的最短路径中,点权和的最大值。核心代码如下所示

for(int v=0; v<n; v++){
	//如果v未访问 && u能到达v && 以u为中介点可以使d[v]更优 
	if(vis[v]==0 && G[u][v]!=INF){
		if(d[u]+G[u][v] < d[v]){
			d[v] = d[u]+G[u][v];
			w[v] = w[u]+weight[v];
			num[v] = num[u];
		} else if(d[u]+G[u][v]==d[v]){	//找到一条相同长度的路径 
			if(w[u]+weight[v]>w[v]){
				w[v] = w[u]+weight[v];
			}
			//最短路径条数需要加上到u的最短路径条数
			num[v] += num[u]; 
		}
	}
}

核心代码是在将结点u添加入最短路径之后更新最短路径数组d[],最短路径条数num[]和最大点权和w[]的部分

从代码中我们可以看到,当有一个结点v满足当u作为中间结点的时候有更短的路径,那么就更新d[v],w[v]和num[v],其中最大点权和w[v]是w[u]加上v的点权的值,最短路径条数与u的最短路径条数相当(因为你是经过u的,相当于继承了u的这个特性);当经过u可以得到相同的最短路径长度的时候,我们知道最短路径的数量变多了,此时的最短路径数量是u和v的最短路径数量和,并且还要判断新的最短路径的最大点权和是否比原先最短路径的最大点权和大。

完整代码:

#include <stdio.h>
#include <algorithm>
#include <iostream>
#include <string.h>
using namespace std;

//最大顶点数
const int MAXV = 510;
const int INF = 1000000000;

//n为顶点数,m为边数,st为起始点,ed为终点
//G为邻接矩阵,weight为点权
//d[]记录最短距离,w[]记录最大点权之和,num[]记录最短路径条数
int n, m, st, ed;
int G[MAXV][MAXV], weight[MAXV];
int d[MAXV], w[MAXV], num[MAXV];

//访问位
int vis[MAXV] = {0};

void Dijkstra(int s){
	fill(d, d+MAXV, INF);	
	memset(num, 0, sizeof(num));
	memset(w, 0, sizeof(w));
	d[s] = 0;		//自己到自己距离为0
	w[s] = weight[s];	//最大点权和
	num[s] = 1;		//最短路径长度为1条
	for(int i=0; i<n; i++){		//循环n次 
		int u=-1, min = INF;	//分别记录当前最短路径的点和最小权值
		for(int j=0; j<n; j++){
			//没有访问过并且距离最短的点 
			if(vis[j]==0 && d[j]<min){		//这第一轮选出的就是起始点 
				u = j;
				min = d[j];
			}
		} 
		if(u==-1) return;		//图不连通
		vis[u] = 1;				//已经访问过 
		for(int v=0; v<n; v++){
			//如果v未访问 && u能到达v && 以u为中介点可以使d[v]更优 
			if(vis[v]==0 && G[u][v]!=INF){
				if(d[u]+G[u][v] < d[v]){
					d[v] = d[u]+G[u][v];
					w[v] = w[u]+weight[v];
					num[v] = num[u];
				} else if(d[u]+G[u][v]==d[v]){	//找到一条相同长度的路径 
					if(w[u]+weight[v]>w[v]){
						w[v] = w[u]+weight[v];
					}
					//最短路径条数需要加上到u的最短路径条数
					num[v] += num[u]; 
				}
			}
		} 
	} 
} 


int main(){
	scanf("%d%d%d%d", &n, &m, &st, &ed);
	for(int i=0; i<n; i++){		//读入点权 
		scanf("%d", &weight[i]);
	}
	int u, v;
	fill(G[0], G[0]+MAXV*MAXV, INF);
	for(int i=0; i<m; i++){
		scanf("%d%d", &u, &v);
		scanf("%d", &G[u][v]);
		G[v][u] = G[u][v];
	}
	Dijkstra(st);
	printf("%d %d\n", num[ed], w[ed]);
	return 0;
}

 

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值