poj 1458 Common Subsequence LCS

Time Limit: 1000MS Memory Limit: 10000KB 64bit IO Format: %lld & %llu

 Status

Description

A subsequence of a given sequence is the given sequence with some elements (possible none) left out. Given a sequence X = < x1, x2, ..., xm > another sequence Z = < z1, z2, ..., zk > is a subsequence of X if there exists a strictly increasing sequence < i1, i2, ..., ik > of indices of X such that for all j = 1,2,...,k, x  ij = zj. For example, Z = < a, b, f, c > is a subsequence of X = < a, b, c, f, b, c > with index sequence < 1, 2, 4, 6 >. Given two sequences X and Y the problem is to find the length of the maximum-length common subsequence of X and Y.

Input

The program input is from the std input. Each data set in the input contains two strings representing the given sequences. The sequences are separated by any number of white spaces. The input data are correct.

Output

For each set of data the program prints on the standard output the length of the maximum-length common subsequence from the beginning of a separate line.

Sample Input

abcfbc         abfcab
programming    contest 
abcd           mnp

Sample Output

4
2
0



#include <iostream>
#include <cstdio>
#include <cstring>


/************************************************

designer:hl
time:2016/11/14
Exe.Time:32 ms
Exe.Memory:892 KB

题目链接:http://poj.org/problem?id=1458

题意:裸LCS

题解:主要的坑是好久没打ACM了。RE了两次。看了别人的代码才意识到dp数组要放到外面
************************************************/

using namespace std;
int dp[222][222];

int main() {
    char m[222], n[222];
    int i, j, k, l;
    //cout <<str;
    while (~scanf("%s%s", m, n)) {
        int mlen = strlen(m);
        int nlen = strlen(n);
        //cout << m << ' ' << n;
        memset(dp, 0, sizeof(dp));
        for (i = 0; i < mlen; i++) {
            for (j = 0; j < nlen; j++) {
                int tempmax = dp[i][j + 1] > dp[i + 1][j] ? dp[i][j + 1] : dp[i + 1][j];
                if (m[i] == n[j]) {
                    dp[i + 1][j + 1] = max(dp[i][j] + 1, tempmax);
                } else {
                    dp[i + 1][j + 1] = tempmax;
                }
            }
        }
        printf("%d\n", dp[mlen][nlen]);
    }
    return 0;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值