eclipse 如何查看ant版本

eclipse模式是自带ant工具的,由于某些脚本限定了ant的版本号和jdk的版本,导致无法运行ant,那么如何查看eclipse的ant的版本呢?

 

进入到eclipse的安装目录的plugins目录,如图所示

 

 

除了Java的系统属性,Ant还定义了一些自己的内置属性: 

basedir project基目录的绝对路径 (与<project>的basedir属性一样)。

ant.file ---- buildfile的绝对路径。

ant.version ----  Ant的版本。

ant.project.name ----  当前执行的project的名字;由<project>的name属性设定.

ant.java.version ----- Ant检测到的JVM的版本; 目前的值有"1.1", "1.2", "1.3" and "1.4".

 

<!-- Check for min build requirements -->
        <condition property="ant.not.ok" value="true">
            <not>
                <or>
                    <contains string="${ant.version}" substring="1.6"/>
                    <contains string="${ant.version}" substring="1.7"/>
                    <contains string="${ant.version}" substring="1.8"/>
                </or>
            </not>
        </condition>
        <condition property="java.not.ok" value="true">
            <not>
                <or>
                    <contains string="${ant.java.version}" substring="1.5"/>
                    <contains string="${ant.java.version}" substring="1.6"/>
                    <contains string="${ant.java.version}" substring="1.7"/>
                </or>
            </not>
        </condition>
阅读更多
个人分类: 开发工具
想对作者说点什么? 我来说一句

没有更多推荐了,返回首页

不良信息举报

eclipse 如何查看ant版本

最多只允许输入30个字

加入CSDN,享受更精准的内容推荐,与500万程序员共同成长!
关闭
关闭