poj2262 筛选法求素数

Goldbach's Conjecture
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 28727 Accepted: 11007

Description

In 1742, Christian Goldbach, a German amateur mathematician, sent a letter to Leonhard Euler in which he made the following conjecture: 
Every even number greater than 4 can be 
written as the sum of two odd prime numbers.

For example: 
8 = 3 + 5. Both 3 and 5 are odd prime numbers. 
20 = 3 + 17 = 7 + 13. 
42 = 5 + 37 = 11 + 31 = 13 + 29 = 19 + 23.

Today it is still unproven whether the conjecture is right. (Oh wait, I have the proof of course, but it is too long to write it on the margin of this page.) 
Anyway, your task is now to verify Goldbach's conjecture for all even numbers less than a million. 

Input

The input will contain one or more test cases. 
Each test case consists of one even integer n with 6 <= n < 1000000. 
Input will be terminated by a value of 0 for n.

Output

For each test case, print one line of the form n = a + b, where a and b are odd primes. Numbers and operators should be separated by exactly one blank like in the sample output below. If there is more than one pair of odd primes adding up to n, choose the pair where the difference b - a is maximized. If there is no such pair, print a line saying "Goldbach's conjecture is wrong."

Sample Input

8
20
42
0

Sample Output

8 = 3 + 5
20 = 3 + 17
42 = 5 + 37
#include<iostream>
#include<string.h>
#include<stdio.h>
#define MAX 1000000
using namespace std;
bool prime1[MAX+1];
int prime2[MAX/2];
int  cal()
{
    prime1[1]=0;prime1[2]=1;
    for(int i=3;i<=MAX;i++)
    {
        if(i%2)prime1[i]=1;
        else prime1[i]=0;
    }
    int count=0;
    for(int i=3;i<=MAX;i++)
    {
        if(prime1[i])
        {
            if(i*i>MAX)break;
            for(int j=i*i;j<=MAX;j+=i)
            {
                prime1[j]=0;
            }
        }
    }
    for(int i=1;i<=MAX;i++)
    {
        if(prime1[i])
        {
            prime2[++count]=i;
        }
    }
    return count;
}
int main()
{
    int count=cal();
    int n;
    while(cin>>n,n)
    {
        bool temp=true;
        for(int i=1;i<=count;i++)
        {
            if(prime2[i]>n)break;
            if(prime1[n-prime2[i]])
            {
                temp=false;
                printf("%d = %d + %d\n",n,prime2[i],n-prime2[i]);
                break;
            }
        }
        if(temp)
        {
            cout<<"Goldbach's conjecture is wrong."<<endl;
        }
    }
    return 0;
}
这个问题是一个筛选法求素数的问题。。第一次做我超时了,主要是在找利用两个素数因子的时候用了一个两层循环没有好好利用prime1.。。。
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值