【字符串入门专题1】D - Period hdu 1358【kmp-最小循环节简单应用】

Period



Problem Description
For each prefix of a given string S with N characters (each character has an ASCII code between 97 and 126, inclusive), we want to know whether the prefix is a periodic string. That is, for each i (2 <= i <= N) we want to know the largest K > 1 (if there is one) such that the prefix of S with length i can be written as AK , that is A concatenated K times, for some string A. Of course, we also want to know the period K.
 

Input
The input file consists of several test cases. Each test case consists of two lines. The first one contains N (2 <= N <= 1 000 000) – the size of the string S. The second line contains the string S. The input file ends with a line, having the number zero on it.
 

Output
For each test case, output “Test case #” and the consecutive test case number on a single line; then, for each prefix with length i that has a period K > 1, output the prefix size i and the period K separated by a single space; the prefix sizes must be in increasing order. Print a blank line after each test case.
 

Sample Input
  
  
3 aaa 12 aabaabaabaab 0
 

Sample Output
  
  
Test case #1 2 2 3 3 Test case #2 2 2 6 2 9 3 12 4
 
题意:按从小到大的顺序每行输出字符串的循环节长度和最小循环节的出现次数

思路:嘻嘻嘻,终于用上最小循环节的总结啦,我是最小循环节总结哦~~,这道题虽然没有用上我喜欢的递归调用输出函数,但是呐,一扫之前那道题带给我糟糕的心情,我就是那道让cdn超时到抓狂的题,总的来说还是比较简单的。


#include<stdio.h>
#include<string.h>
#define N 1100000
char s[N];
int next[N];
void get_next()
{
	int k,j;
	next[0] = k = -1;
	j = 0;
	while(s[j]!='\0')
	{
		if(k == -1||s[k]==s[j])
			next[++j] = ++k;
		else
			k = next[k];
	}
	return;
}
int main()
{
	int n,i;
	int t = 0;
	while(scanf("%d",&n),n!=0)
	{
		t++;
		getchar();
		scanf("%s",s);
		printf("Test case #%d\n",t);
		get_next();
		for(i = 0; i <= n; i ++)
		{//判断循环节的条件
			if(i%(i-next[i]) == 0&&(next[i] != 0&&next[i]!=-1))
				printf("%d %d\n",i,i/(i-next[i]));
		}
		printf("\n");
	}
	return 0;
}








评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值