HDU 5115 M - Dire Wolf 【区间dp】

Dire wolves, also known as Dark wolves, are extraordinarily large and powerful wolves. Many, if not all, Dire Wolves appear to originate from Draenor.
Dire wolves look like normal wolves, but these creatures are of nearly twice the size. These powerful beasts, 8 - 9 feet long and weighing 600 - 800 pounds, are the most well-known orc mounts. As tall as a man, these great wolves have long tusked jaws that look like they could snap an iron bar. They have burning red eyes. Dire wolves are mottled gray or black in color. Dire wolves thrive in the northern regions of Kalimdor and in Mulgore.
Dire wolves are efficient pack hunters that kill anything they catch. They prefer to attack in packs, surrounding and flanking a foe when they can.
— Wowpedia, Your wiki guide to the World of Warcra

Matt, an adventurer from the Eastern Kingdoms, meets a pack of dire wolves. There are N wolves standing in a row (numbered with 1 to N from left to right). Matt has to defeat all of them to survive.

Once Matt defeats a dire wolf, he will take some damage which is equal to the wolf’s current attack. As gregarious beasts, each dire wolf i can increase its adjacent wolves’ attack by b i. Thus, each dire wolf i’s current attack consists of two parts, its basic attack ai and the extra attack provided by the current adjacent wolves. The increase of attack is temporary. Once a wolf is defeated, its adjacent wolves will no longer get extra attack from it. However, these two wolves (if exist) will become adjacent to each other now.

For example, suppose there are 3 dire wolves standing in a row, whose basic attacks ai are (3, 5, 7), respectively. The extra attacks b i they can provide are (8, 2, 0). Thus, the current attacks of them are (5, 13, 9). If Matt defeats the second wolf first, he will get 13 points of damage and the alive wolves’ current attacks become (3, 15).

As an alert and resourceful adventurer, Matt can decide the order of the dire wolves he defeats. Therefore, he wants to know the least damage he has to take to defeat all the wolves.

Input The first line contains only one integer T , which indicates the number of test cases. For each test case, the first line contains only one integer N (2 ≤ N ≤ 200).

The second line contains N integers a i (0 ≤ a i ≤ 100000), denoting the basic attack of each dire wolf.

The third line contains N integers b i (0 ≤ b i ≤ 50000), denoting the extra attack each dire wolf can provide. Output For each test case, output a single line “Case #x: y”, where x is the case number (starting from 1), y is the least damage Matt needs to take.
Sample Input
2
3
3 5 7
8 2 0
10
1 3 5 7 9 2 4 6 8 10
9 4 1 2 1 2 1 4 5 1
Sample Output
Case #1: 17
Case #2: 74
题意:读入n只狼的基础伤害值,和这n只狼对相邻狼的附加伤害值,杀死狼i的伤害值等于第i只狼的基础伤害值加上相邻两头狼的附加伤害值,狼i被杀死之后,附带的伤害值也不再存在,求杀死n只狼的最小伤害值。
思路: 这道题一开始没有看出来是矩阵链乘模型。要求最小伤害值,由于杀狼顺序不同,则伤害值大小也不同,找到状态dp[i][j]是i到j之间的狼全部被杀死的最小伤害值,枚举分界点k是最后一个被杀死的狼的编号,vis[k]是狼k的基础伤害值,value[i]是附加伤害值,可列得状态转移方程式
dp[i][j] = dp[i][k-1] + vis[k]+dp[k+1][j] + value[i-1]+value[j+1]
因为dp[i][j]表示的是i到j之间的所有狼已经被杀死,所以当k(i<k<j)是最后一只被杀的狼时,相邻的狼就只剩下i-1和j+1.
关于循环条件,一开始自己也很迷,后来一看边界状态是dp[i][i] = vis[i]+value[i-1] + value[i+1] ,当我们枚举最后一次策略时,状态转移方程式应包含所有的情况,那么我们将区间长度从1开始枚举到n,将vis[0]+vis[n+1]作为狼1到狼n的最小伤害值的附加伤害值 。
#include<stdio.h>
#include<string.h>
#include<algorithm>
using namespace std;
#define inf 0x3f3f3f3f
const int maxn = 210;
int dp[maxn][maxn],vis[maxn],value[maxn];

int main()
{
	int t=0,T;
	int n,i,j,k,len;
	freopen("in.txt","r",stdin);
	scanf("%d",&T);
	while(T--)
	{
		memset(vis,0,sizeof(vis));
		memset(value,0,sizeof(value));
		memset(dp,0,sizeof(dp));
		scanf("%d",&n);
		for(i = 1; i <= n; i ++)
			scanf("%d",&vis[i]);
		for(i = 1; i <= n; i ++)
			scanf("%d",&value[i]);
		for(len = 1; len <= n; len ++)
		{
			for(i = 1;i +len <= n+1; i ++)
			{
				j = len + i-1;
				dp[i][j] = inf;
				for(k = i; k <= j;k ++)
				{
					dp[i][j] = min(dp[i][j],dp[i][k-1]+vis[k]+dp[k+1][j]+value[i-1]+value[j+1]);
				}
			}
			
		}
		printf("Case #%d: %d\n",++t,dp[1][n]);
	}
	return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值