POJ 2376 Cleaning Shifts (贪心区间最少覆盖)

Cleaning Shifts
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 15489 Accepted: 3951

Description

Farmer John is assigning some of his N (1 <= N <= 25,000) cows to do some cleaning chores around the barn. He always wants to have one cow working on cleaning things up and has divided the day into T shifts (1 <= T <= 1,000,000), the first being shift 1 and the last being shift T.

Each cow is only available at some interval of times during the day for work on cleaning. Any cow that is selected for cleaning duty will work for the entirety of her interval.

Your job is to help Farmer John assign some cows to shifts so that (i) every shift has at least one cow assigned to it, and (ii) as few cows as possible are involved in cleaning. If it is not possible to assign a cow to each shift, print -1.

Input

* Line 1: Two space-separated integers: N and T

* Lines 2..N+1: Each line contains the start and end times of the interval during which a cow can work. A cow starts work at the start time and finishes after the end time.

Output

* Line 1: The minimum number of cows Farmer John needs to hire or -1 if it is not possible to assign a cow to each shift.

Sample Input

3 10
1 7
3 6
6 10

Sample Output

2

Hint

This problem has huge input data,use scanf() instead of cin to read data to avoid time limit exceed.

INPUT DETAILS:

There are 3 cows and 10 shifts. Cow #1 can work shifts 1..7, cow #2 can work shifts 3..6, and cow #3 can work shifts 6..10.

OUTPUT DETAILS:

By selecting cows #1 and #3, all shifts are covered. There is no way to cover all the shifts using fewer than 2 cows.



题意:给你n个小区间,一个大区间T,问使用的最少的小区间覆盖大区间的数量


思路:按照起点排序,然后每次选择能与前一个所选区间接触且到达的最远的那个区间,需要注意[1,5]和[6,10]这种情况是可以相连的。


ac代码:
#include<stdio.h>
#include<math.h>
#include<string.h>
#include<stack>
#include<set>
#include<queue>
#include<vector>
#include<iostream>
#include<algorithm>
#define MAXN 1000100
#define LL long long
#define ll __int64
#define INF 0x7fffffff
#define mem(x) memset(x,0,sizeof(x))
#define PI acos(-1)
#define eps 1e-10
using namespace std;
int gcd(int a,int b){return b?gcd(b,a%b):a;}
int lcm(int a,int b){return a/gcd(a,b)*b;}
LL powmod(LL a,LL b,LL MOD){LL ans=1;while(b){if(b%2)ans=ans*a%MOD;a=a*a%MOD;b/=2;}return ans;}
//head
struct s
{
	int a,b;
}p[MAXN];
int v[MAXN];
bool cmp(s aa,s bb)
{
	if(aa.a==bb.a)
	return aa.b>bb.b;
	return aa.a<bb.a;
}
int main()
{
	int n,m,i;
	while(scanf("%d%d",&n,&m)!=EOF)
	{
		int mi=INF,ma=-1;
		for(i=0;i<n;i++)
		{
			scanf("%d%d",&p[i].a,&p[i].b);
			mi=min(p[i].a,mi);
			ma=max(ma,p[i].b);
		}
		if(mi>1||ma<m)
		{
			printf("-1\n");
			continue;
		}
		sort(p,p+n,cmp);
		mem(v);
		s now;
		int cnt=0;
		now=p[0];
		v[0]=1;cnt++;
		int bz=0;
		int j=-1;
		while(now.b<m)
		{
			int k=-1,M=-1;
			for(i=j+1;i<n;i++)
			{
				if(!v[i])
				{
					if(M<p[i].b&&p[i].a<=now.b+1&&p[i].a>now.a)
					{
						M=p[i].b;
						k=i;
					}
				}
			}
			if(k==-1)
			{
				bz=1;
				break;
			}
			now=p[k];
			j=k;
			v[k]=1;
			cnt++;
		}
		if(bz)
		printf("-1\n");
		else
		printf("%d\n",cnt);
	}
	return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值