cisco三层交换机vlan间通信

cisco三层交换机vlan间通信

在这里插入图片描述

实验拓扑如上

首先,将二层交换机的基本配置配好,添加vlan2,3,并且将端口划分到vlan下面。不要忘记这一步

然后配置三层交换机的基本配置,添加vlan2,3 但是这里有个问题,直接配置trunk会报错,看下面
Switch(config-if)#switchport mode trunk
Command rejected: An interface whose trunk encapsulation is “Auto” can not be configured to “trunk” mode.

三层交换机是不能直接配置trunk的,因为他的接口是auto模式,需要封装一下
Switch(config-if)#switchport trunk encapsulation dot1q
Switch(config-if)#sw
Switch(config-if)#switchport m
Switch(config-if)#switchport mode t
Switch(config-if)#switchport mode trunk
Switch(config-if)#no shu
Switch(config-if)#no shutdown

这样就可以了

接下来,我们要给三层交换机的vlan配置IP地址,当做PC的网关
Switch(config)#interface vlan 2
Switch(config-if)#
%LINK-5-CHANGED: Interface Vlan2, changed state to up

%LINEPROTO-5-UPDOWN: Line protocol on Interface Vlan2, changed state to up

Switch(config-if)#ip add
Switch(config-if)#ip address 192.168.2.254 255.255.255.0
Switch(config-if)#no shu
Switch(config-if)#no shutdown
Switch(config-if)#exit
Switch(config)#in
Switch(config)#interface vlan 3
Switch(config-if)#
%LINK-5-CHANGED: Interface Vlan3, changed state to up

%LINEPROTO-5-UPDOWN: Line protocol on Interface Vlan3, changed state to up

Switch(config-if)#ip add
Switch(config-if)#ip address 192.168.3.254 255.255.255.0
Switch(config-if)#no shu

最后,我们给PC配置一下IP地址,以及网关

然后我们ping一下,那3.0网段的作为实例

ping自己网关通

但是,ping其他vlan不通

这是为什么呢?因为三层交换机的路由功能没有开启,我们来开启一下

Switch(config)#ip routing

然后再ping一下就通了

这是路由功能是要注意的一点

总结一下,本实验有两个重点
1,三层交换机要先封装后,才能配置trunk
sw tr en do
2,三层交换机一定要开启路由功能,否则不同vlan间无法通信
ip routing

已标记关键词 清除标记
相关推荐
©️2020 CSDN 皮肤主题: 游动-白 设计师:白松林 返回首页