poj 3254 Corn Fields

Corn Fields
Time Limit: 2000MS Memory Limit: 65536K
Total Submissions: 17862 Accepted: 9407

Description

Farmer John has purchased a lush new rectangular pasture composed of M byN (1 ≤ M ≤ 12; 1 ≤ N ≤ 12) square parcels. He wants to grow some yummy corn for the cows on a number of squares. Regrettably, some of the squares are infertile and can't be planted. Canny FJ knows that the cows dislike eating close to each other, so when choosing which squares to plant, he avoids choosing squares that are adjacent; no two chosen squares share an edge. He has not yet made the final choice as to which squares to plant.

Being a very open-minded man, Farmer John wants to consider all possible options for how to choose the squares for planting. He is so open-minded that he considers choosing no squares as a valid option! Please help Farmer John determine the number of ways he can choose the squares to plant.

Input

Line 1: Two space-separated integers: M and N
Lines 2.. M+1: Line i+1 describes row i of the pasture with N space-separated integers indicating whether a square is fertile (1 for fertile, 0 for infertile)

Output

Line 1: One integer: the number of ways that FJ can choose the squares modulo 100,000,000.

Sample Input

2 3
1 1 1
0 1 0

Sample Output

        9

 

 

---------------------------------------------

 

状压dp入门题

-------------------------------------------

题目大意:

农夫有一块n*m大小的地,标记为1的是可以放牛的,但是任意两只牛是不能放在相邻的格子上的。然后给你输入值,问你放牛的方案共有多少种,注意可以每个格子都不放牛。

解题思路:一看到n和m这么小,我们就要想到用状压dp。当格子可以放牛时,那么既可以放,也可以不放。

其实类似于dfs的思想,我们可以用1表示可以放牛,然后枚举所有状态。dp[i][j]表示第i行状态为j时的放牛方案,

那么我们可以得到状态转移方程 dp[i][j]+=dp[i-1][0]+.....+dp[i-1][k],k表示为不考虑这一行状态只满足不相邻所有可行状态

 

#include<iostream>
#include<cstring>
#include<cstdio>
using namespace std;
#define kk(x) memset(x,0,sizeof(x))
#define legal(x,y) x&y
const int maxn=100000000;
int ans;
int a[13][13];
int now[13];//表示每一行的状态
int state[100];//共有100种状态
int dp[12][1<<12];
int main()
{
    int n,m;
    while(scanf("%d %d",&n,&m)!=EOF)
    {
        int i,j,t,bb;
        kk(now);
        kk(dp);
        kk(ge);
        kk(state);
        ans=0;
        for(i=0;i<n;i++)
            for(j=0;j<m;j++)
        {
            scanf("%d",&a[i][j]);
            if(a[i][j]==0)
            {
                now[i]+=1<<j;//每一行的状态为1表示不可以放
            }
        }
        bb=0;
        for(i=0;i<1<<m;i++)
        {
            if(i&(i<<1)) continue;
            state[bb++]=i;
        }

       for(i=0;i<bb;i++)
       {
          if(now[0]&state[i]) continue;
          dp[0][i]=1;
       }
       for(i=1;i<n;i++)
       {
           for(j=0;j<bb;j++)
           {
               if(now[i]&state[j]) continue;
               for(t=0;t<bb;t++)
               {
                   if(now[i-1]&state[t]) continue;
                   if(state[t]&state[j]) continue;
                   dp[i][j]=(dp[i][j]+dp[i-1][t])%maxn;
               }

           }

       }
       for(i=0;i<bb;i++)
        ans=(ans+dp[n-1][i])%maxn;
    printf("%d\n",ans);
    }
    return 0;
}

 

 

 

 

 

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值