Codeforces Round #400 (Div. 1 + Div. 2, combined) 776A A Serial Killer

时间限制:1S / 空间限制:256MB

【在线测试提交传送门】

【问题描述】

    Our beloved detective, Sherlock is currently trying to catch a serial killer who kills a person each day. Using his powers of deduction, he came to know that the killer has a strategy for selecting his next victim.

The killer starts with two potential victims on his first day, selects one of these two, kills selected victim and replaces him with a new person. He repeats this procedure each day. This way, each day he has two potential victims to choose from. Sherlock knows the initial two potential victims. Also, he knows the murder that happened on a particular day and the new person who replaced this victim.

You need to help him get all the pairs of potential victims at each day so that Sherlock can observe some pattern.
  杀手有一个谋杀计划,每天都有两个潜在的受害者。每一天,他会选中杀死其中的一人,并用另外一个人代替这个被杀死的人。
  侦探知道初始的两个潜在谋杀对象的名字,也知道接下来每一天的被杀对象和替换者。
  请输出每一天的潜在受害者。

【输入格式】

First line of input contains two names (length of each of them doesn't exceed 10), the two initials potential victims. Next line contains integer n (1 ≤ n ≤ 1000), the number of days.

Next n lines contains two names (length of each of them doesn't exceed 10), first being the person murdered on this day and the second being the one who replaced that person.

The input format is consistent, that is, a person murdered is guaranteed to be from the two potential victims at that time. Also, all the names are guaranteed to be distinct and consists of lowercase English letters.
第一行,包含两个名字(长度均不超过10),表示第一天的两个潜在受害者。
第二行,一个整数n(1 ≤ n ≤ 1000),表示天数。
接下来n行,每行两个名字(长度均不超过10),第一个为当天被杀害的人的名字,第二个为代替的人的名字。
输入的格式是固定的,保证被杀死的对象是给定的潜在对象中的一个,而且不会两个人出现重名,名字有小写字母构成。

【输出格式】

Output n + 1 lines, the i-th line should contain the two persons from which the killer selects for the i-th murder. The (n + 1)-th line should contain the two persons from which the next victim is selected. In each line, the two names can be printed in any order.
输出包含n+1行,第i行包含第i天的两个潜在受害者的名字。

【输入样例1】

ross rachel
4
ross joey
rachel phoebe
phoebe monica
monica chandler

【输出样例1】

ross rachel
joey rachel
joey phoebe
joey monica
joey chandler

【样例1解释】

In first example, the killer starts with ross and rachel. 
• After day 1, ross is killed and joey appears. 
• After day 2, rachel is killed and phoebe appears. 
• After day 3, phoebe is killed and monica appears. 
• After day 4, monica is killed and chandler appears. 
初始时,ross和rachel是潜在受害者;
第1天后,ross被杀害,joey代替他,则joey和rachel是潜在受害者;
第2天后,rachel被杀,phoebe代替他,则joey和phoebe是潜在受害者;
第3天后,phoebe被杀,monica代替他,则joey和monica是潜在受害者;
第4天后,monica被杀,chandler代替他,则joey和chandler是潜在受害者。

【输入样例2】

icm codeforces
1
codeforces technex

【输出样例2】

icm codeforces
icm technex

慎入:以下为解题思路和参考代码,请务必先自行思考

【解题思路】

简单模拟

【参考代码】

#include <bits/stdc++.h>
using namespace std;
const int maxn = 1e5+100;
int main()
{
    string a,b;
    cin>>a>>b;
    int n;
    cin>>n;
    cout<<a<<" "<<b<<endl;
    while(n--)
    {
        string c,d;
        cin>>c>>d;
        if(c==a)
        {
            a = b;
            b = d;
        }
        else if(c==b)
            b = d;
        cout<<a<<" "<<b<<endl;
    }
    return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值