HUST 1010 The Minimum Length (kmp求最小循环节)

题目链接:点击打开链接


1010 - The Minimum Length

时间限制:1秒 内存限制:128兆

题目描述
There is a string A. The length of A is less than 1,000,000. I rewrite it again and again. Then I got a new string: AAAAAA...... Now I cut it from two different position and get a new string B. Then, give you the string B, can you tell me the length of the shortest possible string A.For example, A="abcdefg". I got abcd efgabcdefgabcdefgabcdefg.... Then I cut the red part: efgabcdefgabcde as string B. From B, you should find out the shortest A.
输入
Multiply Test Cases.For each line there is a string B which contains only lowercase and uppercase charactors.The length of B is no more than 1,000,000.
输出
For each line, output an integer, as described above.
样例输入
bcabcab
efgabcdefgabcde
样例输出
3
7
题目大意:给你一串字符串,问这个字符串是由长度多少的字符串重复组成,也就是循环节。用kmp求循环节就好了

#include <stdio.h>
#include <string.h>
#include <iostream>
using namespace std;
char st[1000100];
int next[1001000];
void getnext(char st[],int m)
{
    int j = 0 ,k = -1;
    next[0] = -1;
    while (j < m)
    {
        if (k == -1 || st[j] == st[k] )
        {
            ++j;
            ++k;
            next[j] = k;
        }
        else 
        {
            k = next[k];
        }
        //printf("%d\n",next[j]);
    }
}
int main()
{
    while (cin >> st)
    {
        int len = strlen(st);
        getnext(st,len);
        if(len == 1) 
            printf("1\n");  
        printf("%d\n",len - next[len]);
    }
    return 0;
}




评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值