Financial application- computing future tuition

Financial application- computing future tuition

标签(空格分隔): 程序设计实验 c++

本人学院


Description

Suppose that the tuition for Zhongshan Universtiy is 10000 this year and tuition increases 5% every year. Write a program that reads an integer n(n>0) and uses a loop to compute the cost of the tuition’s worth of the nth year.

If the answer is not a integer, cut off the digits.(e.g. 17.88 -> 17)

If the given n is more than 100, n = n % 100.

Input
An integer n (n>0).

Output
The total cost of four years worth of tuition starting n years from now.

You should set the precision to 2 and fixed.

Sample Input
10Sample Output
16288

Hint:
use cin & cout

读题

my answer

#include<iostream>
using namespace std;

int main() {
    int n;
    cin >> n;
    n %= 100;
    double tuition = 10000;
    while (n--) {
        tuition *= 1.05;
    }
    int ans = static_cast<int>(tuition);
    cout << ans << endl;
    return 0;
}

the standard answer

#include<iostream>
using std::cin;
using std::cout;
using std::endl;

int main() {
  double a = 10000;
  int b;
  cin >> b;
  if (b > 100)
    b = b % 100;
  while (b--) {
    a *= 1.05;
  }
  b = a;
  cout << b << endl;
  return 0;
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值