poj1050 To the Max 暴力DP

To the Max
Time Limit: 1000MS Memory Limit: 10000K
Total Submissions: 39290 Accepted: 20734

Description

Given a two-dimensional array of positive and negative integers, a sub-rectangle is any contiguous sub-array of size 1*1 or greater located within the whole array. The sum of a rectangle is the sum of all the elements in that rectangle. In this problem the sub-rectangle with the largest sum is referred to as the maximal sub-rectangle.
As an example, the maximal sub-rectangle of the array:

0 -2 -7 0
9 2 -6 2
-4 1 -4 1
-1 8 0 -2
is in the lower left corner:

9 2
-4 1
-1 8
and has a sum of 15.

Input

The input consists of an N * N array of integers. The input begins with a single positive integer N on a line by itself, indicating the size of the square two-dimensional array. This is followed by N^2 integers separated by whitespace (spaces and newlines). These are the N^2 integers of the array, presented in row-major order. That is, all numbers in the first row, left to right, then all numbers in the second row, left to right, etc. N may be as large as 100. The numbers in the array will be in the range [-127,127].

Output

Output the sum of the maximal sub-rectangle.

Sample Input

4
0 -2 -7 0 9 2 -6 2
-4 1 -4  1 -1

8  0 -2

Sample Output

15

==================================================================================

题目大意:设矩阵的值为矩阵中整数的和,给出一个N*N的正方形矩阵,求其子矩阵最大值。


解题思路:先把以左上角为顶点的所有矩阵的值算出来,就能算出任意子矩阵的值。

①遍历除左上角顶点外的第二个顶点求矩阵的值:sum[ i ][ j ] = sum[ i-1 ][ j ]+sum[ i ][ j-1 ]-sum[ i-1 ][ j-1 ];

②遍历子矩阵求最大值。

敢使用暴力枚举子矩阵我也是有算过的,时间复杂度 < O(N^4) = O(10^8),1s能过。思路简单粗暴这次就不写注释了。

//Memory: 392K	Time: 110MS

#include<cstdio>

const int N = 101;

int n, sum[N][N];

int main()
{
    scanf("%d", &n);
    for( int i = 1 ; i <= n ; i++ )
        for( int j = 1 ; j <= n ; j++ )
        {
            scanf("%d", &sum[i][j]);
            sum[i][j] += sum[i-1][j]+sum[i][j-1];
            sum[i][j] -= sum[i-1][j-1];
        }
    int ans = sum[1][1];
    for( int i = 1 ; i <= n ; i++ )
        for( int j = 1 ; j <= n ; j++ )
        {
            int Max = -2000000;
            for( int i0 = 1 ; i0 < i ; i0++ )
            {
                int tMax = sum[i][j]-sum[i0][j];
                for( int j0 = 1 ; j0 < j ; j0++ )
                {
                    if( sum[i][j]-sum[i][j0] > tMax )
                        tMax = sum[i][j]-sum[i][j0];
                    if( sum[i][j]-sum[i][j0]-sum[i0][j]+sum[i0][j0] > tMax )
                        tMax = sum[i][j]-sum[i][j0]-sum[i0][j]+sum[i0][j0];
                }
                if( tMax > Max )
                    Max = tMax;
            }
            if( Max > ans )
                ans = Max;
        }
    printf("%d\n", ans);
    return 0;
}

  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值