[GZip 头中的幻数不正确。请确保正在传入 GZip 流]的出错原因之一

之前的几个版本使用和调试都正常,也同样的使用了fiddler2来进行跟踪,突然有一天早上进行改版,发现了

GZip 头中的幻数不正确。请确保正在传入 GZip 流

这个让人发疯的问题,经过使用fiddler2发现,在申请网页的时候发现了并没有使用Accept-Encoding: gzip, deflate这个编码来请求GZIP流,所以才会使程序用GZIP来解读的时候出现错误.

开始的时候以为是网站改版了,可是使用客户告诉我他的正常(就是原来的版本),恶梦开始了,经过了一下午的折腾,百度,就是没找到原因,但是为什么不使用Accept-Encoding: gzip, deflate来请求呢?难道跟我升级FLASH有关系么?卸载,重新安装IE6等等,可是IE去读取网页的时候也不使用Accept-Encoding: gzip, deflate,这更让我头疼了.

第二天一早换一个思路, 在虚拟机上打开,但是之前没有安装fiddler2,这次安装上,后来发现使用原来版本一切正常,看来问题是在开发机上了.

最后发现IE的一个高级选项的[通过代理连接使用HTTP 1.1]这个选项打上勾,就可以了,但是打开Ffiddler2,使用正常的版本,还是一样出错.突然想起来了ie和自己的程序不一样,会不会因为跟踪以后将内容改变了呢?于是关闭了fiddler2并且打开程序一切正常,至此找到了原因.

可能是知识比较少所以找原因也很笨吧.但是这么好的跟踪软件不使用,难道要重新安装系统么?不行的话只能使用原来一直使用的  http analyzer跟踪软件了,但是说真话,这个软件出现错误的机率很多,可能个人原因的问题吧.

总结: 如果说在同一种环境下进行测试那是很不方便的,但是现在有的虚拟机,所以在开发机上可能会出现很多问题,但是到了测试机上却正常,这个时候就应该将[问题]的目光投向开发机上了.

阅读更多
想对作者说点什么? 我来说一句

没有更多推荐了,返回首页

加入CSDN,享受更精准的内容推荐,与500万程序员共同成长!
关闭
关闭