HDU--3466--Proud Merchants--01背包

21 篇文章 0 订阅

Proud Merchants

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 131072/65536 K (Java/Others)
Total Submission(s): 2777    Accepted Submission(s): 1155


Problem Description
Recently, iSea went to an ancient country. For such a long time, it was the most wealthy and powerful kingdom in the world. As a result, the people in this country are still very proud even if their nation hasn’t been so wealthy any more.
The merchants were the most typical, each of them only sold exactly one item, the price was Pi, but they would refuse to make a trade with you if your money were less than Qi, and iSea evaluated every item a value Vi.
If he had M units of money, what’s the maximum value iSea could get?

 

Input
There are several test cases in the input.

Each test case begin with two integers N, M (1 ≤ N ≤ 500, 1 ≤ M ≤ 5000), indicating the items’ number and the initial money.
Then N lines follow, each line contains three numbers Pi, Qi and Vi (1 ≤ Pi ≤ Qi ≤ 100, 1 ≤ Vi ≤ 1000), their meaning is in the description.

The input terminates by end of file marker.

 

Output
For each test case, output one integer, indicating maximum value iSea could get.

 

Sample Input
  
  
2 10 10 15 10 5 10 5 3 10 5 10 5 3 5 6 2 7 3
 

Sample Output
  
  
5 11
 
题意:给你N个物品和M单位的金钱,每个物品有价格a、购买的前提资金b、价值c,要买某个物品,你的钱必须大于等于b,求出最大能获得的价值量

这是个有前提的背包问题,主要是判断物品出场的顺序,本人表示跟上一题一样,准备作死的节奏,就不解析了,等弄明白了再加上



#include <iostream>
#include <cstdio>
#include <cstring>
#include <algorithm>
#define Max(a,b) a>b?a:b
using namespace std;
struct node
{
    int a,b,c;
}s[555];
bool cmp(const node &a,const node &b)
{
    return a.b-a.a<b.b-b.a;	//排序规则
}
int main (void)
{
    int n,m,i,j,k,l;
    int dp[5555];
    while(scanf("%d%d",&n,&m)!=EOF)
    {
        for(i=0;i<n;i++)
        {
            scanf("%d%d%d",&s[i].a,&s[i].b,&s[i].c);
        }
        sort(s,s+n,cmp);
        memset(dp,0,sizeof(dp));
        for(i=0;i<n;i++)	//01背包
        for(j=m;j>=s[i].b;j--)
        dp[j]=Max(dp[j],dp[j-s[i].a]+s[i].c);
        printf("%d\n",dp[m]);
    }
    return 0;
}

总结:今天就做了这两个题,一个是K大值的背包,一个是有前提的背包,这几天有得溜了!


今天搞懂了,特别补上,嘎嘎,物品(A,B,C)表示这个物品金额为A,价值为C,要买它必须金钱不小于B,于是有这样的公式来对两个物品进行优先级排序

A1+B2和A1+B1比较大小,这两个分别表示先A再B和先B再A的起始最小金钱量,因为金钱量是给定的,所以这个最小金钱量越小越好。

比如两个物品

a:1 3 5

b:2 5 5

A1+B2=1+5=6     A2+B1=2+3=5

明显应该是先B再A,比较公式A2+B1<A1+B2也变形为B2-A2>B1-A1这下上面的问题就清楚了,嘎嘎嘎,我真机智,爱死自己了


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值