HDU--杭电--3415--Max Sum of Max-K-sub-sequence--队列--双向队列

Max Sum of Max-K-sub-sequence

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 4883    Accepted Submission(s): 1780


Problem Description
Given a circle sequence A[1],A[2],A[3]......A[n]. Circle sequence means the left neighbour of A[1] is A[n] , and the right neighbour of A[n] is A[1].
Now your job is to calculate the max sum of a Max-K-sub-sequence. Max-K-sub-sequence means a continuous non-empty sub-sequence which length not exceed K.
 


 

Input
The first line of the input contains an integer T(1<=T<=100) which means the number of test cases.
Then T lines follow, each line starts with two integers N , K(1<=N<=100000 , 1<=K<=N), then N integers followed(all the integers are between -1000 and 1000).
 


 

Output
For each test case, you should output a line contains three integers, the Max Sum in the sequence, the start position of the sub-sequence, the end position of the sub-sequence. If there are more than one result, output the minimum start position, if still more than one , output the minimum length of them.
 


 

Sample Input
  
  
4 6 3 6 -1 2 -6 5 -5 6 4 6 -1 2 -6 5 -5 6 3 -1 2 -6 5 -5 6 6 6 -1 -1 -1 -1 -1 -1
 


 

Sample Output
  
  
7 1 3 7 1 3 7 6 2 -1 1 1

 

 

用两种写法弄过,一种调用STL双向队列,一种是直接数组模拟,感觉模拟麻烦点但是耗时很少,双向队列每次都是调用的函数,所以耗时多。

STL双向队列:(734MS)

#include <iostream>
#include <queue>
using namespace std;
int
a[222222],sum[222222];  //sum[n]记录从a[1]加到a[n]的和
deque<int> q;
int
main (void)
{

    int
t,n,m,i,head,end,s;
    cin>>t;
    while
(
t--&&cin>>n>>m)
    {

        sum[0]=0;
        for
(
i=1;i<=n;i++)
        {

            cin>>a[i];
            sum[i]=sum[i-1]+a[i];
        }

        for
(
i=n+1;i<=n+m;i++)
            sum[i]=sum[i-1]+a[i-n];   
        s
=-1e10;head=end=0;  //最大值初始化为-1e10
        q.clear();  //把队列弄干净,初始化双向队列,清空
        for(i=1;i<n+m;i++)
        {

            while
(!
q.empty()&&sum[i-1]<sum[q.back()])  //如果队列不是空的,而且当前数值压入队列会破坏队列元素单调
                q.pop_back();  //那么把队尾元素出队
            while(!q.empty()&&i-q.front()>m)  //如果队列不是空的,而且当前记录的子串长度超过规定范围
                q.pop_front();  //队首元素出队
            q.push_back(i-1);  //把当前数值压入队尾
            if(sum[i]-sum[q.front()]>s)  //当前元素满足条件的最大值大于记录的最大值时进行记录操作
            {
                s=sum[i]-sum[q.front()];
                head=q.front()+1;end=i;
            }
        }

        if
(
head>n)head-=n;
        if
(
end>n)end-=n;
        cout<<s<<" "<<head<<" "<<end<<endl;
    }

    return
0;
}

用数组模拟双向队列:(187MS)


#include <iostream>
#include <cstdio>
#include <cstring>
using namespace
std;
int
a[222222],sum[222222]={0},que[222222];  //que代替队列起记录作用,sum还是一样记录从1到n的和
int
main (void)
{

    int
t,n,m,s,i,j,k,l,max,aa,ss,qian,hou;
    scanf("%d",&t);
    while
(
t--&&scanf("%d%d",&n,&m))
    {

        for
(
i=1;i<=n;i++)
            scanf("%d",&a[i]),a[n+i]=a[i];
        for
(
i=1,sum[0]=0;i<=n+m;i++)
            sum[i]=sum[i-1]+a[i];
        max=-1000000,aa=ss=qian=hou=0;
        for
(
i=1;i<n+m;i++)
        {

            while
(
qian<hou&&sum[i-1]<sum[que[hou-1]])hou--;  //hou即是队尾
            que[hou++]=i-1;  //压入队列数组
            while
(
qian<hou&&i-que[qian]>m)qian++;  /qian即是队首
            if
(
sum[i]-sum[que[qian]]>max)
            {

                max=sum[i]-sum[que[qian]];
                aa=que[qian]+1;ss=i;
            }
        }

        if
(
aa>n)aa-=n;
        if
(
ss>n)ss-=n;
        printf("%d %d %d\n",max,aa,ss);
    }

    return
0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值