HDU 1003Max Sum 动态规划 经典题 最大子序列和

Max Sum
Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 203541    Accepted Submission(s): 47572


Problem Description
Given a sequence a[1],a[2],a[3]......a[n], your job is to calculate the max sum of a sub-sequence. For example, given (6,-1,5,4,-7), the max sum in this sequence is 6 + (-1) + 5 + 4 = 14.


Input
The first line of the input contains an integer T(1<=T<=20) which means the number of test cases. Then T lines follow, each line starts with a number N(1<=N<=100000), then N integers followed(all the integers are between -1000 and 1000).


Output
For each test case, you should output two lines. The first line is "Case #:", # means the number of the test case. The second line contains three integers, the Max Sum in the sequence, the start position of the sub-sequence, the end position of the sub-sequence. If there are more than one result, output the first one. Output a blank line between two cases.


Sample Input
2
5 6 -1 5 4 -7
7 0 6 -1 1 -6 7 -5


Sample Output
Case 1:
14 1 4

Case 2:
7 1 6


Author
Ignatius.L

来源: http://acm.hdu.edu.cn/showproblem.php?pid=1003

#include <iostream>
#include <cstdio>
#include <climits>
using namespace std;
int A[100001],MAXA[100001];
void Handle(int N)///状态转移方程 MAXA(i) = max{F[i],F[i]+MAXA(i-1)}
{
    int Rb=0,Begin=0,Re=0,End=0,MAX=INT_MIN;MAXA[0]=-9999;///丫的,不能设置成INT_MIN ,会在第一次就因为溢出变成正数///设置变量全部从0开始防止出出现全0
    for(int i=1;i<=N;i++)
    {
        if(A[i]>A[i]+MAXA[i-1]) {Begin=End=i; MAXA[i]=A[i];}
        else                    {MAXA[i]=A[i]+MAXA[i-1];End++;}
        if(MAX < MAXA[i])       {Rb=Begin;Re = End;MAX = MAXA[i];}
    }
    printf("%d %d %d\n",MAX,Rb,Re);
}
int main()
{
    //freopen("F:\\test.txt","r",stdin);
    int T;scanf("%d",&T);
    for(int i=1,N;i<=T&&scanf("%d",&N);i++)
    {
        if(i>=2) putchar('\n');
        printf("Case %d:\n",i);
        for(int j=1;j<=N;j++) scanf("%d",&A[j]);Handle(N);
    }
}

来源: http://acm.hdu.edu.cn/viewcode.php?rid=17251534

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值