Number Sequence 找规律

Number Sequence
Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 145337    Accepted Submission(s): 35307


Problem Description
A number sequence is defined as follows:

f(1) = 1, f(2) = 1, f(n) = (A * f(n - 1) + B * f(n - 2)) mod 7.

Given A, B, and n, you are to calculate the value of f(n).


Input
The input consists of multiple test cases. Each test case contains 3 integers A, B and n on a single line (1 <= A, B <= 1000, 1 <= n <= 100,000,000). Three zeros signal the end of input and this test case is not to be processed.


Output
For each test case, print the value of f(n) on a single line.


Sample Input
1 1 3
1 2 10
0 0 0


Sample Output
2
5


Author
CHEN, Shunbao


Source
ZJCPC2004


Recommend
JGShining

来源: http://acm.hdu.edu.cn/showproblem.php?pid=1005

//找规律做法
#include <stdio.h>           // f(n) +7x=A*f(n-1) +B*f(n-2) // 2A7==49 f(n-1),f(n-2)排列   一共49情况
long long  Value[49]={0,1,1};

int A,B;

int Cal(long long n)

{

    for(int i=3;i<=48;i++)

        Value[i] = (A*Value[i-1]+B*Value[i-2])%7;

    return 1;

}

int main()

{



    long long n;

    while(~scanf("%d %d %lld",&A,&B,&n)&&(A||B||n)&&Cal(n))

        printf("%lld\n",Value[n%48==0?48:n%48]);

    return 0;

}

来源: http://acm.hdu.edu.cn/viewcode.php?rid=16559993

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值