hdu 5018

22 篇文章 0 订阅

Problem Description
In mathematical terms, the sequence Fn of Fibonacci numbers is defined by the recurrence relation
F n = F n-1 + F n-2
with seed values F 1 = 1; F 2 = 1 (sequence A000045 in OEIS).
---Wikipedia

Today, Fibonacci takes revenge on you. Now the first two elements of Fibonacci sequence has been redefined as A and B. You have to check if C is in the new Fibonacci sequence.
 

Input
The first line contains a single integer T, indicating the number of test cases. 

Each test case only contains three integers A, B and C.

[Technical Specification]
1. 1 <= T <= 100
2. 1 <= A, B, C <= 1 000 000 000
 

Output
For each test case, output “Yes” if C is in the new Fibonacci sequence, otherwise “No”.
 

Sample Input
  
  
3 2 3 5 2 3 6 2 2 110
 

Sample Output
  
  
Yes No Yes
Hint
For the third test case, the new Fibonacci sequence is: 2, 2, 4, 6, 10, 16, 26, 42, 68, 110…
 

#include<stdio.h>
int main()
 {
 	 int T;
 	 int i,j;
 	 __int64 tempc;
 	 __int64 a,b,c;
 	 scanf("%d",&T);
 	 while(T--)
 	  {
 	  	 scanf("%I64d%I64d%I64d",&a,&b,&c);
 	  	 if(c==a||c==b)     //记住别忘记了初始时给的两个
 	  	  {
 	  	  	 printf("Yes\n");
 	  	  	 continue;
 	  	  }
 	  	 for(i=0;;i++)
 	  	  {
 	  	  	 tempc=a+b;
 	  	  	 if(tempc>c)
 	  	  	   {
 	  	  	   	 printf("No\n");
 	  	  	   	 break;
 	  	  	   }
 	  	  	 if(tempc==c)
 	  	  	  {
 	  	  	  	 printf("Yes\n");
 	  	  	  	 break;
 	  	  	  }
 	  	  	 else
 	  	  	  {
 	  	  	  	
 	  	  	  	 a=b;
 	  	  	  	 b=tempc;
 	  	  	  }
 	  	  }
 	  }
 	return 0;
 }



评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值