poj 1338 Ugly Numbers

Description
Ugly numbers are numbers whose only prime factors are 2, 3 or 5. The sequence
1, 2, 3, 4, 5, 6, 8, 9, 10, 12, …
shows the first 10 ugly numbers. By convention, 1 is included.
Given the integer n,write a program to find and print the n’th ugly number.

Input
Each line of the input contains a postisive integer n (n <= 1500).Input is terminated by a line with n=0.

Output
For each line, output the n’th ugly number .:Don’t deal with the line with n=0.

Sample Input

1
2
9
0

Sample Output

1
2
10

#include<cstdio>
#define maxn 1555
int UN[maxn]={0,1};
int Min(int a,int b){
    return a>b?b:a;
}
void GetUN(){
    int i,a2,a3,a5;
    a2=a3=a5=1;
    for(i=2;i<=1500;i++){
        UN[i]=Min(UN[a2]*2,Min(UN[a3]*3,UN[a5]*5));
        if(UN[i]==UN[a2]*2) a2++;
        if(UN[i]==UN[a3]*3) a3++;
        if(UN[i]==UN[a5]*5) a5++;
    }
}
int main(){
    GetUN();
    int n;
    while(scanf("%d",&n)==1,n){
        printf("%d\n",UN[n]);
    }
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值