POJ-1961(Period)(kmp())

POJ-1961(Period)(kmp())

Description

For each prefix of a given string S with N characters (each character has an ASCII code between 97 and 126, inclusive), we want to know whether the prefix is a periodic string. That is, for each i (2 <= i <= N) we want to know the largest K > 1 (if there is one) such that the prefix of S with length i can be written as A K ,that is A concatenated K times, for some string A. Of course, we also want to know the period K.

Input

The input consists of several test cases. Each test case consists of two lines. The first one contains N (2 <= N <= 1 000 000) – the size of the string S.The second line contains the string S. The input file ends with a line, having the
number zero on it.

Output

For each test case, output "Test case #" and the consecutive test case number on a single line; then, for each prefix with length i that has a period K > 1, output the prefix size i and the period K separated by a single space; the prefix sizes must be in increasing order. Print a blank line after each test case.

Sample Input

3
aaa
12
aabaabaabaab
0

Sample Output

Test case #1
2 2
3 3

Test case #2
2 2
6 2
9 3
12 4

题意:在前i个字符中,循环节出现的次数(要求循环节出现的次数要大于1),比如aabaabaabaab,在前两个字符中a出现了两次,循环节为a。在前6个字符中,循环节出现了2次,循环节为aab,在前9个字符中,循环节出现了3次,循环节为aab;在12个字符中循环节出现了4次,循环节为aab。

My solution:

/*2016.4.11*/

#include<cstdio>
#include<algorithm>
#include<cstring>
using namespace std;
char c[1000100];
int nest[1000100],n;
void getnest()
{
	int i,j,k=0,t;
	i=0;j=-1;
	nest[i]=j;
	while(i<n)
	{
		if(j==-1||c[i]==c[j])
		{
			i++;
			j++;
			t=i-j;//求循环节长度 
			if(j&&i%t==0)//注意j不能等于0,否则循环节出现的次数为1,即:循环节为前i个字符.(不符题意) 
			{
			//	k=1;
				printf("%d %d\n",i,i/t);
			}
			nest[i]=j;
		}
		else
		j=nest[j];
	}
//	if(k==0)
//	printf("0 0\n");//题中所给的测试数据都能找到循环节,因此不用考虑不存在的情况 
}
int main()
{
	int i=0,j,k,m;
	while(scanf("%d",&n)==1&&n)
	{
		i++;
		if(i!=1)//注意格式 
		printf("\n");
		scanf("%s",c);
		printf("Test case #%d\n",i);
		getnest();
	}
	return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值