1077 Eight 八数码问题


     
     
Eight
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 11425 Accepted: 5073 Special Judge

Description

Input

You will receive a description of a configuration of the 8 puzzle. The description is just a list of the tiles in their initial positions, with the rows listed from top to bottom, and the tiles listed from left to right within a row, where the tiles are represented by numbers 1 to 8, plus 'x'. For example, this puzzle  
 1  2  3 

x 4 6
7 5 8

is described by this list:  

1 2 3 x 4 6 7 5 8

Output

You will print to standard output either the word ``unsolvable'', if the puzzle has no solution, or a string consisting entirely of the letters 'r', 'l', 'u' and 'd' that describes a series of moves that produce a solution. The string should include no spaces and start at the beginning of the line.

Sample Input

 2  3  4  1  5  x  7  6  8 

Sample Output

ullddrurdllurdruldr

Source

The 15-puzzle has been around for over 100 years; even if you don't know it by that name, you've seen it. It is constructed with 15 sliding tiles, each with a number from 1 to 15 on it, and all packed into a 4 by 4 frame with one tile missing. Let's call the missing tile 'x'; the object of the puzzle is to arrange the tiles so that they are ordered as: 
 1  2  3  4 

5 6 7 8
9 10 11 12
13 14 15 x

where the only legal operation is to exchange 'x' with one of the tiles with which it shares an edge. As an example, the following sequence of moves solves a slightly scrambled puzzle: 
 1  2  3  4    1  2  3  4    1  2  3  4    1  2  3  4 

5 6 7 8 5 6 7 8 5 6 7 8 5 6 7 8
9 x 10 12 9 10 x 12 9 10 11 12 9 10 11 12
13 14 11 15 13 14 11 15 13 14 x 15 13 14 15 x
r-> d-> r->

The letters in the previous row indicate which neighbor of the 'x' tile is swapped with the 'x' tile at each step; legal values are 'r','l','u' and 'd', for right, left, up, and down, respectively. 

Not all puzzles can be solved; in 1870, a man named Sam Loyd was famous for distributing an unsolvable version of the puzzle, and 
frustrating many people. In fact, all you have to do to make a regular puzzle into an unsolvable one is to swap two tiles (not counting the missing 'x' tile, of course). 

In this problem, you will write a program for solving the less well-known 8-puzzle, composed of tiles on a three by three 
arrangement. 

#include<stdio.h>
#include<string.h>
int fac[]= {1,1,2,6,24,120,720,5040,40320}; //n!
int hash[500000];
int dir[]={-1,-3,1,3};
char a[15];
char ans[]="123456780";
char ansx[500000]={0};
bool move[][4] = {0,0,1,1, 1,0,1,1, 1,0,0,1, 0,1,1,1, 1,1,1,1, 1,1,0,1, 0,1,1,0, 1,1,1,0, 1,1,0,0};
struct ss
{
    int pre;
    int idx;
    int step;
    char x[15];
}t[500000];
int getkey(char *seq)
{
    int i,j,cnt,key=0;
    for(i=0; i<9; i++)
    {
        cnt=0;
        for(j=0; j<i; j++)
            if(seq[j]>seq[i]) cnt++;
        key+=cnt*fac[i];       // cnt<=i
    }
    return key;
}
bool input()
{
    char str[10];
    int num=0;
    for(int i=1; i<=9; i++)
    {
        if(scanf("%s",str)==EOF)  return false;
        if(str[0]=='x')  a[num++]='0';
        else a[num++]=str[0];
    }
    return true;
}
void GetDir(int h)
{
    memset(ansx,0,sizeof(ansx));
    int n=t[h].step;
    for(int i=n;i>=1;i--)
    {

        if(t[h].idx==0)
            ansx[i]='l';
        else if(t[h].idx==1)
            ansx[i]='u';
        else if(t[h].idx==2)
            ansx[i]='r';
        else if(t[h].idx==3)
            ansx[i]='d';
        h=t[h].pre;
    }
    ansx[0]='1';
}
int main()
{
    while(input())
    {
        memset(hash,0,sizeof(hash));
        int head=0,end=1;
        int key=getkey(a);
        hash[key]=1;
        t[0].pre=-1;
        t[0].step=0;
        strcpy(t[0].x,a);
        int z,zz;
        while(head<end)
        {
            if(strcmp(t[head].x,ans)==0) break;
            for(int i=0; i<9; i++)
                if(t[head].x[i]=='0')
                {
                    z=i;
                    break;
                }
            for(int i=0; i<4; i++)
            {
                strcpy(a,t[head].x);
                if(move[z][i]==0)  continue;
                int zz=z+dir[i];
                    char temp=a[z];
                    a[z]=a[zz];
                    a[zz]=temp;
                    int p=getkey(a);
                    if(hash[p]==0)
                    {
                        end++;
                        hash[p]=1;
                        t[end].idx=i;
                        t[end].pre=head;
                        t[end].step=t[head].step+1;
                        strcpy(t[end].x,a);
                    }
            }
            head++;
        }
        if(head>=end) printf("unsolvable/n");
        else
        {
            GetDir(head);
            printf("%s/n",ansx+1);
        }
    }
    return 0;
}

 

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值