A + B Problem II HDU 1002

6 篇文章 0 订阅

Problem Description
I have a very simple problem for you. Given two integers A and B, your job is to calculate the Sum of A + B.

Input
The first line of the input contains an integer T(1<=T<=20) which means the number of test cases. Then T lines follow, each line consists of two positive integers, A and B. Notice that the integers are very large, that means you should not process them by using 32-bit integer. You may assume the length of each integer will not exceed 1000.

Output
For each test case, you should output two lines. The first line is “Case #:”, # means the number of the test case. The second line is the an equation “A + B = Sum”, Sum means the result of A + B. Note there are some spaces int the equation. Output a blank line between two test cases.

Sample Input
2
1 2
112233445566778899 998877665544332211

Sample Output
Case 1:
1 + 2 = 3

Case 2:
112233445566778899 + 998877665544332211 = 1111111111111111110

#include<stdio.h>
#include<string.h>
int main()
{
    int T;
    scanf ("%d", &T);
    int kase = 1;
    while (T --)
    {
        char str_a[1005], str_b[1005];
        scanf ("%s %s", str_a, str_b);
        int a_1[1005], b_1[1005];
        int len_a = strlen(str_a), len_b = strlen(str_b);
        for (int i = len_a - 1, j = 1004; j >= 0; i --, j --)
        {
            if (i >= 0)
                a_1[j] = str_a[i] - '0';
            else
                a_1[j] = 0;
        }
        for (int i = len_b - 1, j = 1004; j >= 0; i --, j --)
        {
            if (i >= 0)
                b_1[j] = str_b[i] - '0';
            else
                b_1[j] = 0;
        }
        int sum[1005];
        for (int i = 0; i < 1005; i ++)
            sum[i] = 0;
        for (int i = 1004; i >= 0; i --)
        {
            sum[i] = sum[i] + a_1[i] + b_1[i];
            if (sum[i] >= 10)
            {
                sum[i-1] ++;
                sum[i] %= 10;
            }
        }
        printf ("Case %d:\n", kase ++);
        printf ("%s + %s = ", str_a, str_b);
        int ans;
        for (int i = 0; sum[i] == 0; i ++)
            ans = i;
        for (int i = ans + 1; i <= 1004; i++)
            printf ("%d", sum[i]);
        puts("");
        if (T != 0)
            puts("");
    }
    return 0;
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值