HDU-1443 Joseph

2 篇文章 0 订阅

Problem Description
The Joseph\\\\’s problem is notoriously known. For those who are not familiar with the original problem: from among n people, numbered 1, 2, …, n, standing in circle every mth is going to be executed and only the life of the last remaining person will be saved. Joseph was smart enough to choose the position of the last remaining person, thus saving his life to give us the message about the incident. For example when n = 6 and m = 5 then the people will be executed in the order 5, 4, 6, 2, 3 and 1 will be saved.

Suppose that there are k good guys and k bad guys. In the circle the first k are good guys and the last k bad guys. You have to determine such minimal m that all the bad guys will be executed before the first good guy.

Input
The input file consists of separate lines containing k. The last line in the input file contains 0. You can suppose that 0 < k < 14.

Output

The output file will consist of separate lines containing m corresponding to k in the input file.

Sample Input
3
4
0

Sample Output
5
30

题意:每个示例输入一个k,共有n=2*k人,求使得前k个出队的都是n人中后k个人里面的(即第k+1至2*k个)的最小m值。

AC代码:

#include <iostream>
using namespace std;

bool find(int k,int m)
{
    int n=2*k;
    int count=0,now=0;
    while(count<k)
    {
        now = (now+m-1)%n;
        if(now<k)//因为我们只需要前k个出队的是后k个,故不需要用队列来模拟
            return false;
        else
        {
            count++;
            n--;
            now%=n;
        }
    }
    return true;
}

int main()
{
    int k;
    int ans[14]={0};//用来保存已求过的答案,避免重复,也可以直接先打表,不保存会TLE
    //第一次提交TLE了还以为是自己的算法问题,然后手动输入打表AC的,后来去查别人的解法才发现是因为自己没保存已求过的答案导致超时的
    //int ans[]={2,7,5,30,169,441,1872,7632,1740,93313,459901,1358657,2504881};
    while(cin>>k&&k)
    {
        if(ans[k-1]!=0)
            cout<<ans[k-1]<<endl;
        else
        {
            for(int i=k+1;;++i)
            {
                if(find(k,i))
                {
                    cout<<i<<endl;
                    ans[k-1]=i;
                    break;
                }
                if(i%k==0&&(i/k)%2==0)
                {
                    i+=k;
                    continue;
                }
            }
        }
    }
    return 0;
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

算法之旅

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值