Ubuntu16.04 常用软件集锦[超实惠]

Ubuntu系统重装,考虑到系统空间的根目录不足,/和/usr目录还是啥空间反正是不够了,gparted,lvm之类的已经无能为力,只好重新分区安装,同时这次安装一下Ubuntu16.04。使用的是UltraISO制作的U盘启动系统盘进行系统安装(参考:http://jingyan.baidu.com/article/a3761b2b66fe141577f9aa51.html)。

改变源和更新系统

  • 执行命令:sudo apt-get update&&sudo apt-get upgrade

设置root账户密码

  • 设置root账户密码命令:sudo passwd root
  • 输入当前账户密码
  • 设置root账户密码

拼音输入法

之前安装的是搜狗拼音,这次安装16.04选择的是汉语各种中文,已经把拼音集成了。所以这次没有安装输入法。不过麻烦的就是去个我的文件夹,原本是cd Downloads的命令要改成cd 下载.

后来发现还是搜狗好用,比方说你要当前的时间,直接输入sj就会出现,但是其他的输入法比方说Ubuntu自带的就没有这个功能,好吧,装搜狗.

  • 安装包下载地址:http://pinyin.sogou.com/linux/
  • 执行安装命令:sudo dpkg -i sogoupinyin_2.0.0.0072_amd64.deb
  • 缺少依赖包,安装失败,安装依赖包:sudo apt-get install -f
  • 依赖包安装完成,重新安装:sudo dpkg -i sogoupinyin_2.0.0.0072_amd64.deb
  • 安装成功

在启动里直接搜索Fcitx Configuration,打开后在Input Method里删除除了Sougou拼音以外的其它中文输入法(可能略有延迟,Sougou拼音没出来),确保除了Sougou拼音外,只有一个Keyboard – English(US),若没有这一项就在下方点击加号"+"添加这一项.

浮动菜单

  • 下方的浮动图标工具栏:docky
  • 安装方法:sudo apt-get install docky

便签Xpad

  • 不是和docky集成的便签
  • 安装方法:sudo apt-get install xpad
  • 参考:http://article.yeeyan.org/view/140496/124205/

WPS

  • 首先去下载:http://linux.wps.cn/
  • 之后安装:sudo dpkg -i wps-office_10.1.0.5444~a20_amd64.deb

    因版权导致的字体缺失问题

  • 首先,百度 wps_symbol_fonts.zip 并下载(百度网盘:http://pan.baidu.com/share/link?shareid=2003500809&uk=52711591),假设已经放到了“下载”这个目录下
  • 创建文字目录:sudo mkdir /usr/share/fonts/wps-office
  • 返回下载目录,将字体包复制过去:sudo cp -r /usr/share/fonts/wps-office
  • 切换到/usr/share/fonts/wps-office目录,并解压字体包:sudo unzip wps_symbol_fonts.zip
  • 解压完成后删除字体包:sudo rm -r wps_symbol_fonts.zip
  • 问题完美解决
  • 参考:http://blog.sina.com.cn/s/blog_c97546fe0101hhso.html

Chrome

  • 下载命令:wget https://dl.google.com/linux/direct/google-chrome-stable_current_amd64.deb
  • 安装命令: sudo dpkg -i google-chrome-stable_current_amd64.deb
  • 因为软件包依赖关系不满足发生错误,执行该命令:sudo apt-get install -f
  • 输入y确定执行
  • 再次执行安装命令:sudo dpkg -i google-chrome-stable_current_amd64.deb
  • 安装完成
  • 参考:http://jingyan.baidu.com/article/a681b0de18071e3b1843463b.html

     插件安装(需要VPN上应用商店

        连上VPN后,登录 Google 账户,插件自动同步了

配置Express VPN

  • 在官网,登录账户并下载linux版本的deb安装包:sudo dpkg -i expressvpn_1.0.1_amd64.deb
  • 激活命令:expressvpn activate
  • 输入激活码
  • 尝试连接命令:expressvpn connect
  • 提示连接成功:Connecting to Hong Kong – 1…    100.0%
    Connected.
  • 断开连接:expressvpn disconnect
  • 连接失败或者其他问题,参考:https://www.expressvpn.cc/support/vpn-setup/app-for-linux/

安装Python环境

     安装Anaconda

  • 安装包(sh文件)下载地址:https://www.continuum.io/downloads
  • 创建安装目录:sudo mkdir /usr/local/lib/anaconda2
  • 执行安装包的sh文件:./Anaconda2-4.0.0-Linux-x86_64.sh
  • 同意条款,输入安装路径:/usr/local/lib/anaconda2
  • 再次执行安装:./Anaconda2-4.0.0-Linux-x86_64.sh
  • 安装失败,已经存在(/usr/local/lib/anaconda2)目录,删除目录:sudo rmdir /usr/local/lib/anaconda2
  • 这次带sudo进行安装:sudo ./Anaconda2-4.0.0-Linux-x86_64.sh
  • 输入同意yes条款,输入指定目录
  • 安装成功

     安装PyCharm(需预先配置JDK

      配置JDK(搁浅暂时,还是先配hadoop+spark环境

  • 下载最新的JDK:http://www.oracle.com/technetwork/java/javase/downloads/index-jsp-138363.html
  • 参考:Hadoop2.7.2 配置文件

      安装PyCharm

  • 官网下载PyCharm的tar.gz格式
  • 使用命令进行解压:tar -xvzf pycharm.tar.gz
  • 解压后将pycharm文件夹移动到/usr/local/lib/目录下
  • 进入pycharm的bin目录,执行命令:./pycharm.sh
  • 激活:https://xn--90agrrk8e.xn--p1ai/pycharm-activate-key-3-4-5/

     安装ipython notebook(Jupyter)

  • 安装命令:sudo aptget install ipythonnotebook
  • 启动INB命令:ipython notebook pylab inline ip 0.0.0.0
  • 参考:http://121.42.47.99/yuenshome/wordpress/?p=2622
  • 其实没有必要装,安装完Anoconda

安装CUDA(CUDA 7.5暂不支持Ubuntu16.04,可以强装

  • 将从Nvidia下载好的cuda.deb包进行安装:sudo dpkg -i cuda-repo-ubuntu1404-7-5-local_7.5-18_amd64.deb
  • 无法使用nvcc
  • 更新包:sudo apt-get update
  • 安装cuda:sudo apt-get install cuda
  • 提示错误,E:无法定位包:cuda
  • 再次尝试使用nvcc,显示cuda版本命令:nvcc -V
  • 提示需要安装nvidia-cuda-toolkit
  • 尝试安装sudo apt install nvidia-cuda-toolkit
  • 安装完成,测试cuda编译版本命令:nvcc -V
  • 显示CUDA版本:nvcc: NVIDIA (R) Cuda compiler driver
    Copyright (c) 2005-2015 NVIDIA Corporation
    Built on Tue_Aug_11_14:27:32_CDT_2015
    Cuda compilation tools, release 7.5, V7.5.17
  • 安装成功
  • 参考:http://blog.csdn.net/xizero00/article/details/43227019(用处不大)
  • 后来,我参考了:http://www.zhihu.com/question/43711830
  • nvidia-smi命令可以使用
  • 在软件中心设置完成Nvidia的官方驱动后(安装完了驱动)
  • sudo apt-get udpate
  • sudo apt-get install nvidia-cuda-toolkit
  • 完成
  • 现在试试 nvidia-smi 命令是可以用的
  • 强装的方法这里就不写了,等CUDA 8.0

安装虚拟机

     安装VirtualBox(迷之成功

  • 选择对应版本并下载两个文集(virtualbox和其增强包Extension Pack),地址:https://www.virtualbox.org/wiki/Linux_Downloads
  • 执行安装命令:sudo dpkg -i virtualbox-5.0_5.0.20-106931~Ubuntu~xenial_i386.deb
  • 提示错误,依赖不满足
  • 修复并安装依赖:sudo apt-get install -f
  • 重新安装:sudo dpkg -i virtualbox-5.0_5.0.20-106931~Ubuntu~xenial_i386.deb
  • 安装完成
  • 安装后启动报错,无法使用
  • 卸载之前的安装
  • 下载官网的Ubuntu14.04 Trusty版本的VBOX deb包,重新安装
  • 在经历了好几次安装卸载后,迷之成功

     安装增强包

  • 增强包可以让VBOX增强功能,拥有usb3.0,更高的分辨率等功能。
  • VBOX安装完成后打开VBOX,菜单栏选择管理-全局设定-扩展-添加包(倒三角符号)-找到刚下载的包并选择-进行安装
  • 安装完成

    安装VMware Workstation 12 Pro(虚拟机无法共享黏贴板,设置共享文件夹

  • 下载安装包:http://www.vmware.com/cn/products/workstation/workstation-evaluation
  • 修改文件管理权限:sudo chmod +x VMware-Workstation-Full-12.1.1-3770994.x86_64.bundle
  • 安装:sudo ./VMware-Workstation-Full-12.1.1-3770994.x86_64.bundle
  • 可用Linux版注册密钥:5A02H-AU243-TZJ49-GTC7K-3C61N
  • 参考:
  • http://beikeit.com/post-513.html
  • http://blog.sciencenet.cn/blog-522898-476831.html

     安装增强包VMware Tools

  • 安装完一台虚拟机后,比方说WinXP的,进入虚拟机系统
  • 打开VMware =》 菜单选中VM =》点击 Install VMware Tools
  • 在虚拟机内部自动挂载某个盘进行安装(没有VBOX一劳永逸方便)
  • 声音貌似有问题(我装的是WinXP SP3 32),另外似乎粘帖板也不能共享

安装NVIDIA驱动

目前 Graphic Drivers PPA 只支持 Nvidia 驱动,支持的 Ubuntu 版本为 Ubuntu 12.04.1 到 15.10。

  • 使用如下命令添加Graphic Drivers PPA命令:sudo addaptrepository ppa:graphicsdrivers/ppa
  • 更新或安装最新Nvidia驱动程序命令:sudo aptget update && sudo aptget install nvidia355
  • 参考:http://www.sysgeek.cn/ubuntu-install-nvidia-drivers-ppa/
  • 安装失败,貌似因为是系统问题
  • 后来,我参考了:http://www.zhihu.com/question/43711830
  • 安装nvidia-361。
  • 在软件中心-驱动-设置英伟达的官方驱动
  • 安装完成

启用截图

  • 其实已经安装好了,这里可以试着安装看看:sudo apt-get install gnome-screenshot
  • 锁定到启动器

粘帖板管理工具

之前在Ubuntu14.04下安装过,但是记不清是不是下面这个,下面这个的安装命令如下:

  • 添加包:sudo add-apt-repository ppa:diodon-team/stable
  • 更新包:sudo apt-get update
  • 安装:sudo apt-get install diodon
  • 参考:http://www.oschina.net/p/diodon

安装系统清理工具 BleachBit

  • 安装命令:sudo apt-get install bleachbit
  • 安装完成

播放器VLC,SMPlayer,Mpv

  • 安装SMPlayer:sudo apt-get install smplayer
  • 安装vlc播放器:sudo apt-get install vlc
  • 安装mpv播放器:sudo apt-get install mpv
  • 安装本机自身播放器的编解码器和其他软件的许可证:sudo apt-get install ubuntu-restricted-extras(参考:http://linuxnote.blog.163.com/blog/static/168521570201077111721773/,http://blog.sina.com.cn/s/blog_59e0c16f0100sndj.html)

桌面配置工具 Unity Tweak Tool

  • 添加包命令:sudo add-apt-repository ppa:freyja-dev/unity-tweak-tool-daily
  • 更新包管理器:sudo apt-get update
  • 安装命令:sudo apt-get install unity-tweak-tool
  • 安装完成,但失败无法启用
  • 参考:http://www.linuxidc.com/Linux/2013-02/79830.htm
  • 貌似后来通过软件中心安装成功,可以使用了

MarkDown工具Haroopad

  • 官网下载其64位的deb包:http://pad.haroopress.com/user.html
  • 执行安装命令:sudo dpkg -i haroopad-v0.13.1-x64.deb
  • 安装完成
  • 进入设置让其显示数学公式和行号
  • 注:对 MarkDown 文件编辑完成后,点击保存关闭的时候提示是否保存,是因为文件权限的问题,使用命令:chmod 777 ./test.md 解决。

安装git和svn

     安装并配置git(暂时不配用不上

  • 安装命令:sudo apt-get install git
  • 安装完成

     安装并配置svn(暂时不配用不上

  • 安装命令:sudo apt-get install subversion
  • 安装完成

安装LAMPP环境

  • 安装命令:sudo apt-get install lamp-server^
  • 安装完成

     安装phpmyadmin(无法打开

  • 参考:http://jingyan.baidu.com/article/9113f81b24aa9a2b3214c721.html
  • 安装命令:sudo apt-get install phpmyadmin
  • 建立软连接,首先到cd /var/www/html/目录,建立软连接:sudo ln -s /usr/share/phpmyadmin phpmyadmin
  • 在浏览器里localhost/phpmyadmin,提示有错误,百度该错误
  • 进而找到某论坛给出的方法(http://www.oschina.net/question/1393935_133166)
  • 安装php_mbstring命令:sudo apt-get install  php-mbstring

安装VIM

若之前没有安装,可以用gedit代替。

  • 安装命令:sudo apt-get install vim

     VIM配置

  • 默认配置文件是:/etc/vim/vimrc
  • 在家目录下建立自己的配置文件切换到家目录 #cd ~
  • touch一个名为.vimrc的文件(以.开头的为隐藏文件)#touch .vimrc#vi .vimrc
  • 输入以下配置:
  • 完成后输入:wq退出保存。
  • 参考:Ubuntu下更改Vim配置文件打造C/C++风格_Linux教程_Linux公社-Linux系统门户网站  http://www.linuxidc.com/Linux/2011-08/41265.htm

安装替换系统默认字体

  • 安装文泉字体,通过tweak替换
  • 参考:http://www.linuxdiyf.com/linux/11653.html

安装Adobe flash

  • 安装命令:sudo apt-get install flashplugin-installer

安装压缩软件RAR

  • 安装命令:sudo apt-get install rar

提高电池的寿命并且减少过热

笔记本过热是一个普遍的问题,它不仅仅存在于ubuntu中,也存在与其他的操作系统中,过热会影响电池的寿命,从 ubuntu12.10开始,tupiter就是解决过热的最好的工具。可惜的是这个项目已经停止开发了,你可以使用TLP或者CPUFREQ来代替 jupiter,安装TLP通过使用下面的命令:

  • sudo add-apt-repository ppa:linrunner/tlp
  • sudo apt-get update
  • sudo apt-get install tlp tlp-rdw
  • sudo tlp start

使用TPL是不需要进行配置的。

  • 参考:http://www.zhihu.com/question/20509148

安装云盘Dropbox(需VPN

  • sudo apt-get install nautilus-dropbox
  • sudo apt-get install libappindicator1

下载的是一个下载器,完成后可能需要VPN来下载Dropbox主程序。

启动器albert

  • sudo add-apt-repository ppa:nilarimogard/webupd8
  • sudo apt-get update
  • sudo apt-get install albert
  • 安装完成后,在启动器里输入albert打开并设置热键(我这里设置的热键是`+Ctrl)
  • 参考:
  • http://www.zhihu.com/question/20509148
  • http://www.webupd8.org/2015/01/albert-fast-lightweight-quick-launcher.html

笔记本Zim Desktop Wiki

摘抄知乎:Zim的所有笔记都以文本格式存储,以文件夹方式管理;同时支持HTML、LaTeX、Markdown、rst等多种格式,可在模板中选择(虽然我没用过);支持全文搜索、标签检索。默认是一种类似Markdown的wiki格式,支持列表、任务列表,可以插入图片、附件、LaTeX公式(需先安装latex相关软件),插入的图片可单独指定一个附件目录,可输出为HTML、LaTeX、Markdown、rst。

  • 安装命令:sudo apt-get install zim
  • 参考:www.zhihu.com/question/20509148

思维导图 Xmind

  • 下载安装包:http://www.xmind.net/download/linux/
  • 安装:sudo dpkg -i xmind-7-update1-linux_amd64.deb
  • 安装失败,缺少依赖包,安装依赖包:sudo apt-get install -f
  • 重新安装:sudo dpkg -i xmind-7-update1-linux_amd64.deb

自动调节屏幕色温Redshift

  • 根据日出日落时间(设定经纬度)自动调节电脑屏幕的亮度、色彩(色温),保护眼睛
    没用之前我一直觉得这种东西有必要吗,一直在后台耗费系统资源?用过了之后,我才发现真的很有必要呀!开启软件时,眼睛是一种很柔和的感觉,关闭则是对比很明显的刺眼蓝光。这才发现我的搓本屏幕颜色严重偏蓝,而之前我笔记本的亮度也因为刺眼的蓝光调的过低了。
  • 安装命令:sudo apt-get install redshift
  • 启动命令:redshift
  • 可以加到系统启动里面:vim /etc/rc.local
  • 将启动命令添加进去,保存并推出
  • 参考:http://www.zhihu.com/question/20509148
  • 最近,也找到一个win下的屏幕色温调节工具:flux

Linux下的完美帅气终端Guake

  • 安装命令:sudo apt-get install guake

     常用快捷键

  • 调用:键盘F12
  • 新建终端选项卡:Ctrl+Shift+T
  • 关闭当前选项卡:Ctrl+Shift+W
  • 切换到当前选项卡右边:Ctrl+Page Down
  • 切换到当前选项卡左边:Ctrl+Page Up

安装支付宝浏览器安全控件

  • 下载地址:https://download.alipay.com/alipaysc/linux/aliedit/1.0.3.20/aliedit.tar.gz
  • 使用浏览器或者命令行进行下载:wget https://download.alipay.com/alipaysc/linux/aliedit/1.0.3.20/aliedit.tar.gz
  • 解压:tar -zxvf aliedit.tar.gz
  • 安装:./aliedit.sh
阅读更多
博主设置当前文章不允许评论。

没有更多推荐了,返回首页