POJ_1459_Power Network_网络流问题

POJ 1459
Power Network
Time Limit: 2000MS        Memory Limit: 32768K
Total Submissions: 26441        Accepted: 13745

Description
A power network consists of nodes (power stations, consumers and dispatchers) connected by
 power transport lines. A node u may be supplied with an amount s(u) >= 0 of power,
 may produce an amount 0 <= p(u) <= pmax(u) of power, may consume an amount 0 <= c(u) <= min
 (s(u),cmax(u)) of power, and may deliver an amount d(u)=s(u)+p(u)-c(u) of power.
 The following restrictions apply: c(u)=0 for any power station, p(u)=0 for any consumer,
  and p(u)=c(u)=0 for any dispatcher. There is at most one power transport line (u,v) from
   a node u to a node v in the net; it transports an amount 0 <= l(u,v) <= lmax(u,v) of power
    delivered by u to v. Let Con=Σuc(u) be the power consumed in the net. The problem is to
     compute the maximum value of Con.

An example is in figure 1. The label x/y of power station u shows that p(u)=x and pmax(u)=y.
 The label x/y of consumer u shows that c(u)=x and cmax(u)=y. The label x/y of power transport
  line (u,v) shows that l(u,v)=x and lmax(u,v)=y. The power consumed is Con=6. Notice that
  there are other possible states of the network but the value of Con cannot exceed 6.

Input
There are several data sets in the input. Each data set encodes a power network. It starts
with four integers: 0 <= n <= 100 (nodes), 0 <= np <= n (power stations), 0 <= nc <= n
(consumers), and 0 <= m <= n^2 (power transport lines). Follow m data triplets (u,v)z,
 where u and v are node identifiers (starting from 0) and 0 <= z <= 1000 is the value
 of lmax(u,v). Follow np doublets (u)z, where u is the identifier of a power station and
  0 <= z <= 10000 is the value of pmax(u). The data set ends with nc doublets (u)z, where
   u is the identifier of a consumer and 0 <= z <= 10000 is the value of cmax(u). All
   input numbers are integers. Except the (u,v)z triplets and the (u)z doublets, which
   do not contain white spaces, white spaces can occur freely in input. Input data terminate
    with an end of file and are correct.

Output
For each data set from the input, the program prints on the standard output the maximum
amount of power that can be consumed in the corresponding network. Each result has an
integral value and is printed from the beginning of a separate line.

Sample Input

2 1 1 2 (0,1)20 (1,0)10 (0)15 (1)20
7 2 3 13 (0,0)1 (0,1)2 (0,2)5 (1,0)1 (1,2)8 (2,3)1 (2,4)7
         (3,5)2 (3,6)5 (4,2)7 (4,3)5 (4,5)1 (6,0)5
         (0)5 (1)2 (3)2 (4)1 (5)4

Sample Output

15
6
*/
/*
    前四个数分别表示,m个点,np个发电站,nc个用户,n条边
    接下去是n条边 ------(u,v)w,w表示边(u,v)的最大流量;
    np个发电站---(u)w,w表示发电站u能提供的最大流量;
    nc个用户的信息(v)w,w表示每个用户v能接受的最大流量。
    
    网络流问题 加源点汇点,转化成了一般的最大网络流问题

*/

#include <stdio.h>
#include <string.h>
#include <queue>
using namespace std;
const int N = 105;
const int inf = 0x3f3f3f3f;
int g[N][N];
int flow[N][N];
int p[N];
int x[N];
int s,e;
int Edmonds_Karp()
{
	memset(flow,0,sizeof(flow));
	queue<int> Q;
	int f = 0,v,u;
	while(1)
	{
		memset(x,0,sizeof(x));
		x[s] = inf;
		Q.push(s);
		while(!Q.empty())
		{
			u = Q.front();
			Q.pop();
			for(v=s;v<=e;v++)
			{
				if(!x[v] && g[u][v]>flow[u][v])
				{
					p[v] = u;
					Q.push(v);
					x[v] = min(x[u],g[u][v]-flow[u][v]);
				}
			}
		}
		if(x[e]==0)
		{
			return f;
		}
		for(int i=e;i!=s;i=p[i])
		{
			flow[p[i]][i] += x[e];
			flow[i][p[i]] -= x[e];
		}
		f += x[e];
	}
}
int main()
{
	int n,a,b,m,i;
	while(scanf("%d%d%d%d",&n,&a,&b,&m)!=EOF)
	{
		int u,v,w;
		memset(g,0,sizeof(g));
		for(i=1;i<=m;i++)
		{
			scanf(" (%d,%d)%d",&u,&v,&w);
			g[++u][++v] = w;
		}
		for(i=1;i<=a;i++)
		{
			scanf(" (%d)%d",&u,&w);
			g[0][++u] = w;
		}
		for(i=1;i<=b;i++)
		{
			scanf(" (%d)%d",&v,&w);
			g[++v][n+1] = w;
		}
		n++;
		s = 0; e = n;
		printf("%d\n",Edmonds_Karp());
	}
	return 0;
}


  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值