POJ_3259_Wormholes【判断负权】

Time Limit:2000MS     Memory Limit:65536KB     64bit IO Format:%I64d & %I64u
Submit Status

Description

While exploring his many farms, Farmer John has discovered a number of amazing wormholes.
 A wormhole is very peculiar because it is a one-way path that delivers you to its destination
  at a time that is BEFORE you entered the wormhole! Each of FJ's farms comprises N (1 ≤ N ≤ 500)
   fields conveniently numbered 1..N, M (1 ≤ M ≤ 2500) paths, and W (1 ≤ W ≤ 200) wormholes.
As FJ is an avid time-traveling fan, he wants to do the following: start at some field, travel through
 some paths and wormholes, and return to the starting field a time before his initial departure. Perhaps
  he will be able to meet himself :) .
To help FJ find out whether this is possible or not, he will supply you with complete maps to F (1 ≤ F ≤ 5)
of his farms. No paths will take longer than 10,000 seconds to travel and no wormhole can bring FJ back in
time by more than 10,000 seconds.
Input
Line 1: A single integer, F. F farm descriptions follow.
Line 1 of each farm: Three space-separated integers respectively: N, M, and W
Lines 2.. M+1 of each farm: Three space-separated numbers ( S, E, T) that describe, respectively: a
bidirectional path between S and E that requires T seconds to traverse. Two fields might be connected by
more than one path.
Lines M+2.. M+ W+1 of each farm: Three space-separated numbers ( S, E, T) that describe, respectively: A
one way path from S to E that also moves the traveler back T seconds.
Output
Lines 1.. F: For each farm, output "YES" if FJ can achieve his goal, otherwise output "NO" (do not include
the quotes).
Sample Input
2
3 3 1
1 2 2
1 3 4
2 3 1
3 1 3
3 2 1
1 2 3
2 3 4
3 1 8
Sample Output
NO

YES


#include <stdio.h>
#include <string.h>
#define inf 0x3f3f3f3f
int dist[505];
int count;
struct Node 
{
	int x;
	int y;
	int z;
}s[5100];
int add_adge(int x,int y,int z)
{
	s[count].x = x;
	s[count].y = y;
	s[count++].z = z;
}
int main()
{
	int T;
	scanf("%d",&T);
	while(T--)
	{
		int n,m,w;
		int i,j;
		scanf("%d%d%d",&n,&m,&w);
		int _x,_y,_z;
		count = 1;
		for(i=1;i<=m;i++)
		{
			scanf("%d%d%d",&_x,&_y,&_z);	
			add_adge(_x,_y,_z);
			add_adge(_y,_x,_z);
		}
		for(i=1;i<=w;i++)
		{
			scanf("%d%d%d",&_x,&_y,&_z);
			add_adge(_x,_y,-_z);
		}
		memset(dist,inf,sizeof(dist));
		dist[1] = 0;
		printf("%d\n",count);
		for(j=1;j<n;j++)
		{
			for(i=1;i<=count;i++)
			{
				if(dist[s[i].y]>dist[s[i].x]+s[i].z)
				{
					dist[s[i].y]=dist[s[i].x]+s[i].z;
				}
			}
		}
		int f = 0;
		for(i=1;i<=count;i++)
		{
			if(dist[s[i].y]>dist[s[i].x]+s[i].z)
			{
				f = 1;
			}
			if(f==1)
			{
				printf("YES\n");
				break;
			}
		}
		if(!f)
		{
			printf("NO\n");
		}
	}
	return 0;
}
SPFA优化版
#include<cstdio>
#include<string>
#include<queue>
using namespace std; 
const int Max = 520+10;  
int head[Max];    
bool vis[Max];  
int dist[Max]; 
int cun[Max]; 
struct Node  
{  
    int v;  
    int w;  
    int next;  
}edge[Max*10]; 
int n,m,w; 
int num;  
void init()  
{  
    memset(dist,0x3f,sizeof(dist));  
    memset(vis,false,sizeof(vis));  
    memset(cun,0,sizeof(cun));
}  
void add_edge(int u,int v,int w)  
{  
    edge[num].v = v;  
    edge[num].w = w;  
    edge[num].next = head[u];  
    head[u] = num ++ ;  
}  
bool SPFA(int u)  
{  
    init();  
    int v,i,w;  
	deque<int> Q;
	Q.push_back(u);  
    dist[u] = 0;  
    vis[u] = true;  
    cun[1] = 1; 
    while(!Q.empty())  
    {  
        u = Q.front();  
        Q.pop_front();  
        vis[u] = false;  
        for(i=head[u];i!=-1;i=edge[i].next)  
        {  
            v = edge[i].v;  
            w = edge[i].w;  
            if(dist[v] > dist[u] + w)  
            {  
                dist[v] = dist[u] + w;  
                if(!vis[v])  
                {  
                	cun[v]++;
                    vis[v] = true;  
                   	if(cun[u] > n)
						return true;
					if(!Q.empty() && dist[v] < dist[Q.front()])
						Q.push_front(v);
					else
						Q.push_back(v);  
                }   
            }  
        }  
    }
	return false;  
}    
int main()
{
	int T;
	scanf("%d",&T);
	while(T--)
	{
        num = 0;  
        memset(head,-1,sizeof(head));  
		scanf("%d%d%d",&n,&m,&w);	
		int from,to,val;
		for(int i=0;i<m;i++)
		{
			scanf("%d%d%d",&from,&to,&val);
			add_edge(from,to,val);
			add_edge(to,from,val); //双向的
		}
		for(int i=0;i<w;i++)
		{
			scanf("%d%d%d",&from,&to,&val);
			add_edge(from,to,-val);
		}
		if(SPFA(1))
			puts("YES");
		else
			puts("NO");
	}
	return 0;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值