dp Charm Bracelet

5 篇文章 0 订阅

描述

Bessie has gone to the mall's jewelry store and spies a charm bracelet. Of course, she'd like to fill it with the best charms possible from the N(1 ≤ N≤ 3,402) available charms. Each charm iin the supplied list has a weight Wi(1 ≤ Wi≤ 400), a 'desirability' factor Di(1 ≤ Di≤ 100), and can be used at most once. Bessie can only support a charm bracelet whose weight is no more than M(1 ≤ M≤ 12,880).

Given that weight limit as a constraint and a list of the charms with their weights and desirability rating, deduce the maximum possible sum of ratings.


输入Line 1: Two space-separated integers: N and M
Lines 2..N+1: Line i+1 describes charm i with two space-separated integers: W i and D i输出Line 1: A single integer that is the greatest sum of charm desirabilities that can be achieved given the weight constraints样例输入
4 6
1 4
2 6
3 12
2 7
样例输出
23

我的Runtime error代码

#include<iostream>
#include<cstring>
#include<vector>
#include<algorithm>
using namespace std;
struct Node{
    int w;
    int d;
    double dw;
    Node(){}

}node[3410];
bool cp(Node a,Node b){
        if(a.dw>b.dw)
            return true;
        else
            if(a.dw==b.dw&&a.w<b.w)
                return  true;
}
int main(){
    int n,m;
    cin>>n>>m;
    for(int i=0;i<n;i++){
        cin>>node[i].w;
        cin>>node[i].d;
        node[i].dw=1.0*node[i].d/node[i].w;
    }
    sort(node,node+n,cp);
    int ct=0;
    for(int i=0;i<n;i++){
        if(node[i].w<=m){
            ct+=node[i].d;
            m-=node[i].w;
        }else continue;
    }
    cout<<ct;
}

//意识到是dp了,但是还是不会写。

大佬的AC代码

// 背包问题(动态规划)
#include <iostream> 
#include <cstdio>
#include <cstring>
#define MAXN 3402
#define MAXM 12880
using namespace std;

int main(){
    int N, M, W[MAXN+5], D[MAXN+5], dp[MAXM+5];
    while(scanf("%d%d", &N, &M) != EOF){
        for(int i=0; i<N; i++){
            scanf("%d%d", &W[i], &D[i]);

        }
        memset(dp, 0, sizeof(dp));
        for(int i=0; i<N; i++){
            for(int left_w=M; left_w>=W[i]; left_w--){
                dp[left_w] = max(dp[left_w-W[i]]+D[i], dp[left_w]);
            }
        }
        printf("%d\n", dp[M]);
    }   
    return 0;
}
PS:dp数组记录当容量为当前下标时,最高的价值;dp数组是动态覆盖的;每放一个物品就会更新一遍dp数组;当放第i个物品的时候,i-1及其之前的都已经计算好了。
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值