ZOJ - 3953 Intervals(贪心)

Intervals

Time Limit: 1 Second       Memory Limit: 65536 KB       Special Judge

Chiaki has n intervals and the i-th of them is [liri]. She wants to delete some intervals so that there does not exist three intervals ab and c such that a intersects with bb intersects with c and c intersects with a.

Chiaki is interested in the minimum number of intervals which need to be deleted.

Note that interval a intersects with interval b if there exists a real number x such that la ≤ x ≤ ra and lb ≤ x ≤ rb.

Input

There are multiple test cases. The first line of input contains an integer T, indicating the number of test cases. For each test case:

The first line contains an integer n (1 ≤ n ≤ 50000) -- the number of intervals.

Each of the following n lines contains two integers li and ri (1 ≤ li < ri ≤ 109) denoting the i-th interval. Note that for every 1 ≤ i < j ≤ nli ≠ lj or ri ≠ rj.

It is guaranteed that the sum of all n does not exceed 500000.

Output

For each test case, output an integer m denoting the minimum number of deletions. Then in the next line, output m integers in increasing order denoting the index of the intervals to be deleted. If m equals to 0, you should output an empty line in the second line.

Sample Input
1
11
2 5
4 7
3 9
6 11
1 12
10 15
8 17
13 18
16 20
14 21
19 22
Sample Output
4
3 5 7 10

Author:  LIN, Xi

Source: The 17th Zhejiang University Programming Contest Sponsored by TuSimple

代码:

#include<iostream>
#include<cstdio>
#include<cstring>
#include<algorithm>

using namespace std;

const int N = 50005;


struct node
{
    int s,e,id;
    bool operator < (const node & p)const
    {
        if(s == p.s)
            return e < p.e;
        else
            return s < p.s;
    }
}p[N],tmp[4];

bool judge(node *a)
{
    node x = a[0];
    node y = a[1];
    node z = a[2];
    return x.e >= y.s && y.e >= z.s && x.e >= z.s;
}
bool cmp(node a,node b)
{
    return a.e > b.e;
}

int ind[N];
int main()
{
    int t,n;
    cin>>t;
    while(t--)
    {
        scanf("%d",&n);
        for(int i = 0;i < n;i++)
        {
            scanf("%d%d",&p[i].s,&p[i].e);
            p[i].id = i+1;
        }
        int num = 0;
        sort(p,p+n);
        tmp[0] = p[0];
        tmp[1] = p[1];
        for(int i = 2;i < n;i++)
        {
            tmp[2] = p[i];
            sort(tmp,tmp+3);
            bool flag = false;
            if(judge(tmp))
                flag = true;
            sort(tmp,tmp+3,cmp);
            if(flag)
            {
                ind[num++] = tmp[0].id;
                swap(tmp[0],tmp[2]);
            }
        }

        sort(ind,ind+num);
        printf("%d\n",num);
        printf("%d",ind[0]);
        for(int i = 1;i < num;i++)
            printf(" %d",ind[i]);
        printf("\n");
    }
    return 0;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值