1012 The Best Rank (25 point(s)) - C语言 PAT 甲级

1012 The Best Rank (25 point(s))

To evaluate the performance of our first year CS majored students, we consider their grades of three courses only: C - C Programming Language, M - Mathematics (Calculus or Linear Algrbra), and E - English. At the mean time, we encourage students by emphasizing on their best ranks – that is, among the four ranks with respect to the three courses and the average grade, we print the best rank for each student.

For example, The grades of C, M, E and A - Average of 4 students are given as the following:

StudentID C M E A
310101 98 85 88 90
310102 70 95 88 84
310103 82 87 94 88
310104 91 91 91 91

Then the best ranks for all the students are No.1 since the 1st one has done the best in C Programming Language, while the 2nd one in Mathematics, the 3rd one in English, and the last one in average.

Input Specification:

Each input file contains one test case. Each case starts with a line containing 2 numbers N and M (≤2000), which are the total number of students, and the number of students who would check their ranks, respectively. Then N lines follow, each contains a student ID which is a string of 6 digits, followed by the three integer grades (in the range of [0, 100]) of that student in the order of C, M and E. Then there are M lines, each containing a student ID.

Output Specification:

For each of the M students, print in one line the best rank for him/her, and the symbol of the corresponding rank, separated by a space.

The priorities of the ranking methods are ordered as A > C > M > E. Hence if there are two or more ways for a student to obtain the same best rank, output the one with the highest priority.

If a student is not on the grading list, simply output N/A.

Sample Input:

5 6
310101 98 85 88
310102 70 95 88
310103 82 87 94
310104 91 91 91
310105 85 90 90
310101
310102
310103
310104
310105
999999

Sample Output:

1 C
1 M
1 E
1 A
3 A
N/A

题目大意:

N 个学生,M 个查询,三门成绩C,M,E 和平均分 A,四个分数对应四个排名;

对于每个查询,输出查询学生的最好排名和对应分数,若名次相同,按 A > C > M > E 顺序输出最好排名;

设计思路:
  1. 输入过程中,记录每门成绩 1 - 100 分对应的人数
  2. 得分为 i 的排名,等于得分大于 i 的总人数加 1
  3. 每一次查询对应一次计算和输出

注:本程序中未存储每个学生对应的四个排名,若对同一学生重复查询需要重复计算(数据量较少,超时的可能性很小~~)

编译器:C (gcc)
#include <stdio.h>

struct student
{
        int id;
        int score[4];
};

int main(void)
{
        int n, m, id, scores[4][102] = {{0}};
        struct student students[2000];
        int i, j, k;

        scanf("%d%d", &n, &m);
        for (i = 0; i < n; i++) {
                struct student *s = students + i;
                scanf("%d%d%d%d", &s->id, &s->score[1], &s->score[2], &s->score[3]);
                s->score[0] = (s->score[1] + s->score[2] + s->score[3]) / 3.0 + 0.5;
                for (j = 0; j < 4; j++)
                        scores[j][s->score[j]]++;
        }

        for (i = 0; i < m; i++) {
                scanf("%d", &id);
                for (j = 0; j < n && students[j].id != id; j++)
                        ;

                if (j == n) {
                        puts("N/A");
                } else {
                        int ranks[4]= {0}, score, max = 3;

                        for (k = 3; k >= 0; k--) {
                               for (score = 100; score >= students[j].score[k]; score--)
                                       ranks[k] += scores[k][score + 1];
                               ranks[k]+= 1;
                               if (ranks[k] <= ranks[max])
                                       max = k;
                        }
                        printf("%d %c\n", ranks[max], "ACME"[max]);
                }


        }
        return 0;
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值