【poj 1383】Labyrinth

题目链接:点击打开链接


Labyrinth
Time Limit: 2000MS Memory Limit: 32768K
Total Submissions: 4702 Accepted: 1761

Description

The northern part of the Pyramid contains a very large and complicated labyrinth. The labyrinth is divided into square blocks, each of them either filled by rock, or free. There is also a little hook on the floor in the center of every free block. The ACM have found that two of the hooks must be connected by a rope that runs through the hooks in every block on the path between the connected ones. When the rope is fastened, a secret door opens. The problem is that we do not know which hooks to connect. That means also that the neccessary length of the rope is unknown. Your task is to determine the maximum length of the rope we could need for a given labyrinth.

Input

The input consists of T test cases. The number of them (T) is given on the first line of the input file. Each test case begins with a line containing two integers C and R (3 <= C,R <= 1000) indicating the number of columns and rows. Then exactly R lines follow, each containing C characters. These characters specify the labyrinth. Each of them is either a hash mark (#) or a period (.). Hash marks represent rocks, periods are free blocks. It is possible to walk between neighbouring blocks only, where neighbouring blocks are blocks sharing a common side. We cannot walk diagonally and we cannot step out of the labyrinth. 
The labyrinth is designed in such a way that there is exactly one path between any two free blocks. Consequently, if we find the proper hooks to connect, it is easy to find the right path connecting them.

Output

Your program must print exactly one line of output for each test case. The line must contain the sentence "Maximum rope length is X." where Xis the length of the longest path between any two free blocks, measured in blocks.

Sample Input

2
3 3
###
#.#
###
7 6
#######
#.#.###
#.#.###
#.#.#.#
#.....#
#######

Sample Output

Maximum rope length is 0.
Maximum rope length is 8.

Hint

Huge input, scanf is recommended. 
If you use recursion, maybe stack overflow. and now C++/c 's stack size is larger than G++/gcc




题意:给你一个m*n迷宫,里面有'#'和'.'两种字符,求距离最远的两个'.'之间的距离。

题解:首先找到任意一个点的坐标(x0,y0),然后以该坐标为起点bfs整个迷宫找最长路,找到该坐标对应最长路的终点(x1,y1),再以(x1,y1)为起点bfs整个迷宫找最长路


注意:不要搞错m和n的次序,尤其是在读入过程和遍历过程。我写时好几次都出现内存读写错误- _ -||

#include<cstdio>
#include<cstring>
#include<queue>
#include<algorithm>
#define max 1000+10
using namespace std;
struct node
{
	int x,y,step;
};
node no,ne;
int n,m,sx,sy,ans;//ans是最长路,表示最后结果 
char grid[max][max];
bool vis[max][max];
void get()
{
	bool flag=false;
	for(int i=0;i<m;i++){
		scanf("%s",grid[i]);
		if(flag) continue;//找到一个之后不用再找第二个 
		for(int j=0;j<n;j++){
			if(grid[i][j]=='.'){
				sx=i;
				sy=j;
				flag=true;
			}
		}
	}
}
bool judge(int x,int y)//判断下一位的移动是否越界 
{
	return x>=0 && x<m && y>=0 && y<n && grid[x][y] != '#' && !vis[x][y];
}
void bfs(int x,int y)
{
	queue<node> o;
	int dir[4][2]={{1,0},{0,1},{-1,0},{0,-1}};
	memset(vis,false,sizeof(vis));
	node no={x,y,0};
	o.push(no);
	ans=0;
	while(!o.empty()){
		no=o.front();
		o.pop();
		for(int k=0;k<4;k++)
		{
			ne.x=no.x+dir[k][0];
			ne.y=no.y+dir[k][1];
			ne.step=no.step+1;
			if(judge(ne.x,ne.y))
			{
				vis[ne.x][ne.y]=true;
				if(ne.step>ans)
				{
					ans=ne.step;
					sx=ne.x;
					sy=ne.y;
				}
				o.push(ne);
			}
		}
	}
}
void solve()
{
	bfs(sx,sy);//找(x1,y1) 
	bfs(sx,sy);//找最长路 
	printf("Maximum rope length is %d.\n",ans);
}
int main()
{
	int t;
	scanf("%d",&t);
	while(t--){
		scanf("%d%d",&n,&m);
		get();
		solve();
	}
	return 0;
}








  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值