PAT 乙级 1028. 人口普查(20)

1028. 人口普查(20)

时间限制
200 ms
内存限制
65536 kB
代码长度限制
8000 B
判题程序
Standard
作者
CHEN, Yue

某城镇进行人口普查,得到了全体居民的生日。现请你写个程序,找出镇上最年长和最年轻的人。

这里确保每个输入的日期都是合法的,但不一定是合理的——假设已知镇上没有超过200岁的老人,而今天是2014年9月6日,所以超过200岁的生日和未出生的生日都是不合理的,应该被过滤掉。

输入格式:

输入在第一行给出正整数N,取值在(0, 105];随后N行,每行给出1个人的姓名(由不超过5个英文字母组成的字符串)、以及按“yyyy/mm/dd”(即年/月/日)格式给出的生日。题目保证最年长和最年轻的人没有并列。

输出格式:

在一行中顺序输出有效生日的个数、最年长人和最年轻人的姓名,其间以空格分隔。

输入样例:
5
John 2001/05/12
Tom 1814/09/06
Ann 2121/01/30
James 1814/09/05
Steve 1967/11/20
输出样例:
3 Tom John


#include<cstdio>
#include<algorithm>
using namespace std;

const int MAXN = 100000 + 5;

typedef struct people
{
	char name[10];
	int y;
	int m;
	int d;

	bool operator < (const struct people &b)const
	{
		if (this->y != b.y) return this->y < b.y;
		else if (this->m != b.m) return this->m < b.m;
		else return this->d < b.d;
	}
}p;

p arr[MAXN];
bool cmp(p a, p b)//时间从小到大,即年龄从大到小
{
	return a< b;
}

int main()
{
	int n;
	int nowy = 2014, nowm = 9, nowd = 6;
	while (scanf("%d", &n) != EOF)
	{
		int i = 0;
		int cnt = 0;//有效生日的个数
		for (; i < n;i++)
		{
			p nowp = { "haha", nowy, nowm, nowd };
			p newp;
			scanf("%s %d/%d/%d", newp.name, &newp.y, &newp.m, &newp.d);
			p temp = nowp; temp.y -= 200;

			//大于现在的时间或者小于200年前的今天
			if ((nowp < newp)||(newp<temp))//要在结构体中定义<符号, 			
				continue;
			else{ arr[cnt++] = newp; }
		}

		sort(arr, arr + cnt, cmp);

		if (cnt>0)
		 printf("%d %s %s\n",cnt, arr[0].name, arr[cnt - 1].name);
		else printf("0\n");
	}

	return 0;
}


#include<stdio.h>  
//#include<iostream>  

#include<algorithm>
using namespace std;
typedef struct people
{
	char name[6];
	int y;
	int m;
	int d;
	bool operator < (const struct people &b)const
	{
		if (this->y != b.y) return this->y < b.y;
		else if (this->m != b.m) return this->m < b.m;
		else return this->d < b.d;
	}

}p;

bool cmp(p p1, p p2)
{
	return p1<p2;
}


int main()
{
	int n, i;
	p *a;
	p temp, nowp;
	temp.y = 1814; temp.m = 9; temp.d = 6;
	nowp.y = 2014; nowp.m = 9; nowp.d = 6;
	while (~scanf("%d", &n))
	{
		a = (p *)malloc(n*sizeof(p));
		i = 0;
		int cnt = 0;//有效生日的个数
		for (; i < n; i++)
		{
			p newp;
			scanf("%s%d/%d/%d", newp.name, &newp.y, &newp.m, &newp.d);
			if ((nowp<newp) || (newp<temp))//大于现在的时间或者小于200年前的今天
				continue;
			else
				a[cnt++] = newp;
		}
		sort(a, a + cnt, cmp);
		if (cnt>0) printf("%d %s %s\n", cnt, a[0].name, a[cnt - 1].name);
		else printf("0\n");
		free(a);
	}
	return 0;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值