HDU 1258 Sum It Up (还是DFS)

153 篇文章 0 订阅
29 篇文章 0 订阅

Sum It Up

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 5691    Accepted Submission(s): 2967


Problem Description
Given a specified total t and a list of n integers, find all distinct sums using numbers from the list that add up to t. For example, if t=4, n=6, and the list is [4,3,2,2,1,1], then there are four different sums that equal 4: 4,3+1,2+2, and 2+1+1.(A number can be used within a sum as many times as it appears in the list, and a single number counts as a sum.) Your job is to solve this problem in general.
 

Input
The input will contain one or more test cases, one per line. Each test case contains t, the total, followed by n, the number of integers in the list, followed by n integers x1,...,xn. If n=0 it signals the end of the input; otherwise, t will be a positive integer less than 1000, n will be an integer between 1 and 12(inclusive), and x1,...,xn will be positive integers less than 100. All numbers will be separated by exactly one space. The numbers in each list appear in nonincreasing order, and there may be repetitions.
 

Output
For each test case, first output a line containing 'Sums of', the total, and a colon. Then output each sum, one per line; if there are no sums, output the line 'NONE'. The numbers within each sum must appear in nonincreasing order. A number may be repeated in the sum as many times as it was repeated in the original list. The sums themselves must be sorted in decreasing order based on the numbers appearing in the sum. In other words, the sums must be sorted by their first number; sums with the same first number must be sorted by their second number; sums with the same first two numbers must be sorted by their third number; and so on. Within each test case, all sums must be distince; the same sum connot appear twice.
 

Sample Input
  
  
4 6 4 3 2 2 1 1 5 3 2 1 1 400 12 50 50 50 50 50 50 25 25 25 25 25 25 0 0
 

Sample Output
  
  
Sums of 4: 4 3+1 2+2 2+1+1 Sums of 5: NONE Sums of 400: 50+50+50+50+50+50+25+25+25+25 50+50+50+50+50+25+25+25+25+25+25
 

Source


思路:先把输入的数据镜像排序,从大到小依次搜索.
去重是关键!

AC代码:

#include <iostream>
#include <cstring>
#include <algorithm>
using namespace std;
int sum,n;
int a[20];
int ans[20];
bool flag;
bool cmp(int x,int y)
{
    return x>y;
}
void DFS(int x,int num,int start,int endd)//将要搜索的值,目前的和,开始位置,结束位置
{
    if(num>sum)
        return;
    if(num==sum)
    {
        cout<<ans[0];
        for(int i=1;i<endd;i++)
            cout<<"+"<<ans[i];
        cout<<endl;
        flag=true;
    }
    for(int i=start;i<n;i++)
    {
        ans[endd]=a[i];
        DFS(a[i],num+a[i],i+1,endd+1);
        while(i+1<n&&a[i]==a[i+1])//搜索完毕后,若下一个搜索的数仍与当前相同,则跳过直至不相同
            i++;
    }
}
int main()
{
    while(cin>>sum>>n)
    {
        if(sum==0&&n==0)
            break;
        int sum2=0;
        for(int i=0; i<n; i++)
        {
            cin>>a[i];
            sum2+=a[i];
        }
        cout<<"Sums of "<<sum<<":"<<endl;
        if(sum2<sum)
        {
           cout<<"NONE"<<endl;
           continue;
        }
        sort(a,a+n,cmp);
        flag=false;
        DFS(0,0,0,0);
        if(!flag)
        {
            cout<<"NONE"<<endl;
        }
    }
    return 0;
}

AC代码2:
#include <iostream>
#include <algorithm>
using namespace std;
int a[15];
int ans[15];
int sum,n;
bool flag;
bool cmp(int x,int y)
{
    return x>y;
}
void DFS(int now,int start,int endd)
{
    if(now==sum)
    {
        cout<<ans[0];
        for(int i=1;i<endd;i++)
            cout<<"+"<<ans[i];
        cout<<endl;
        flag=true;
    }
    for(int i=start;i<n;i++)
    {
        if(i==start||a[i-1]!=a[i])
        {
            ans[endd]=a[i];
            DFS(now+a[i],i+1,endd+1);
        }
    }
}
int main()
{
    while(cin>>sum>>n,sum,n)
    {
        int s=0;
        for(int i=0; i<n; i++)
        {
            cin>>a[i];
            s+=a[i];
        }
        cout<<"Sums of "<<sum<<":"<<endl;
        if(s<sum)
        {
            cout<<"NONE"<<endl;
            continue;
        }
        flag=false;
        sort(a,a+n,cmp);
        DFS(0,0,0);
        if(!flag)
            cout<<"NONE"<<endl;
    }
    return 0;
}



  • 0
    点赞
  • 3
    收藏
    觉得还不错? 一键收藏
  • 1
    评论
评论 1
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值