HDU 1078 FatMouse and Cheese (记忆化搜索)

FatMouse and Cheese

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 7730    Accepted Submission(s): 3202


Problem Description
FatMouse has stored some cheese in a city. The city can be considered as a square grid of dimension n: each grid location is labelled (p,q) where 0 <= p < n and 0 <= q < n. At each grid location Fatmouse has hid between 0 and 100 blocks of cheese in a hole. Now he's going to enjoy his favorite food.

FatMouse begins by standing at location (0,0). He eats up the cheese where he stands and then runs either horizontally or vertically to another location. The problem is that there is a super Cat named Top Killer sitting near his hole, so each time he can run at most k locations to get into the hole before being caught by Top Killer. What is worse -- after eating up the cheese at one location, FatMouse gets fatter. So in order to gain enough energy for his next run, he has to run to a location which have more blocks of cheese than those that were at the current hole.

Given n, k, and the number of blocks of cheese at each grid location, compute the maximum amount of cheese FatMouse can eat before being unable to move. 
 

Input
There are several test cases. Each test case consists of 

a line containing two integers between 1 and 100: n and k 
n lines, each with n numbers: the first line contains the number of blocks of cheese at locations (0,0) (0,1) ... (0,n-1); the next line contains the number of blocks of cheese at locations (1,0), (1,1), ... (1,n-1), and so on. 
The input ends with a pair of -1's. 
 

Output
For each test case output in a line the single integer giving the number of blocks of cheese collected. 
 

Sample Input
  
  
3 1 1 2 5 10 11 6 12 12 7 -1 -1
 

Sample Output
  
  
37
 

Source

Zhejiang University Training Contest 2001


原题链接:http://acm.hdu.edu.cn/showproblem.php?pid=1078


题意:老鼠从(0,0)开始走,每次最多只能走k步停下来,停下的这个位置只能比上一个停留的位置大,并获取其价值,每次只能水平或垂直走,问最大能得到的价值


记忆化搜索

AC代码1

#include <iostream>
#include <cstring>
#include <algorithm>
using namespace std;
int n,k;
int a[105][105],sum[105][105];
int dir[4][2]={0,1,1,0,0,-1,-1,0};
bool OK(int x,int y)
{
    if(x<0||x>=n||y<0||y>=n)
        return false;
    return true;
}
int DFS(int x,int y)
{
    int ans=0;
    if(sum[x][y]) return sum[x][y];
    for(int i=0;i<4;i++)
    {
        for(int j=1;j<=k;j++)
        {
            int xx=x+dir[i][0]*j;
            int yy=y+dir[i][1]*j;
            if(OK(xx,yy)&&a[xx][yy]>a[x][y])
            {
                /**
                int k=DFS(xx,yy);
                ans=max(ans,k);
                */
                ans=max(ans,DFS(xx,yy));
            }
        }
    }
    sum[x][y]=ans+a[x][y];
    return sum[x][y];
}
int main()
{
    while(cin>>n>>k)
    {
        if(n==-1&&k==-1)
            break;
        for(int i=0;i<n;i++)
            for(int j=0;j<n;j++)
                cin>>a[i][j];
        memset(sum,0,sizeof(sum));
        cout<<DFS(0,0)<<endl;
    }
    return 0;
}

AC代码2,网上看到的,效率好高!

//dp[i][j]表示从点i,j处开始能获得的最多cheese
#include <iostream>
#include <string.h>
#include <stdio.h>
#include <algorithm>
using namespace std;
int n,k,dp[101][101],mapp[101][101];
int dfs(int a,int b)
{
    if(dp[a][b]) return dp[a][b];
    dp[a][b] = mapp[a][b];
    for(int i = 1; i<=k; i++)
    {
        if(a+i<n&&mapp[a+i][b]>mapp[a][b])
            dp[a][b] = max(dp[a][b],dfs(a+i,b)+mapp[a][b]);
        if(a-i>=0&&mapp[a-i][b]>mapp[a][b])
            dp[a][b] = max(dp[a][b],dfs(a-i,b)+mapp[a][b]);
        if(b-i>=0&&mapp[a][b-i]>mapp[a][b])
            dp[a][b] = max(dp[a][b],dfs(a,b-i)+mapp[a][b]);
        if(b+i<n&&mapp[a][b+i]>mapp[a][b])
            dp[a][b] = max(dp[a][b],dfs(a,b+i)+mapp[a][b]);
    }
    return dp[a][b];
}

int main(void)
{
    while(scanf("%d %d",&n,&k)!=EOF)
    {
        if(n==-1&&k==-1) break;
        for(int i = 0; i<n; i++)
        {
            for(int j = 0; j<n; j++)
                scanf("%d",&mapp[i][j]);
        }
        memset(dp,0,sizeof(dp));
        printf("%d\n",dfs(0,0));
    }
}


普通搜索超时代码:

#include <iostream>
#include <cstring>
using namespace std;
int n,k;
int a[105][105];
int maxa;
int dir[4][2]={0,1,1,0,0,-1,-1,0};
bool OK(int x,int y)
{
    if(x<0||x>=n||y<0||y>=n)
        return false;
    return true;
}
void DFS(int x,int y,int sum)
{
    if(sum>maxa)
    {
        maxa=sum;
    }
    for(int i=1;i<=k;i++)
    {
        for(int j=0;j<4;j++)
        {
            int xx=x+dir[j][0]*i;
            int yy=y+dir[j][1]*i;
            if(OK(xx,yy)&&a[xx][yy]>a[x][y])
            {
                DFS(xx,yy,sum+a[xx][yy]);
            }
        }
    }
}
int main()
{
    while(cin>>n>>k)
    {
        if(n==-1&&k==-1)
            break;
        for(int i=0;i<n;i++)
            for(int j=0;j<n;j++)
                cin>>a[i][j];
        maxa=0;
        DFS(0,0,a[0][0]);
        cout<<maxa<<endl;
    }

}


  • 1
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 2
    评论
评论 2
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值