HDU 3111 Sudoku(数独,还是深搜)

153 篇文章 0 订阅
29 篇文章 0 订阅

Sudoku

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 464    Accepted Submission(s): 302


Problem Description
A Sudoku puzzle, once solved, is a 9x9 grid of digits organized as a 3x3 grid of smaller 3x3 units. Each of the nine rows must contain every positive digits exactly once, as do each column and also each 3x3 unit. The puzzle is to start from a partially filled 9x9 grid and to fill in the remaining cells using only logic. The puzzle maker usually makes sure that the solution will be unique and that it can be reached using deduction only, without guessing.

This number placing game is gaining popularity in the west, and every second newspaper publishes weekly instances of the puzzle. Somewhere at the head of one such newspaper, someone decided that buying individual instances from a puzzle maker would be too expansive, and instead decided to steal puzzles from other newspapers and also to print randomly generated Sudoku-like grids.

One week later, his assistant gets stuck with the job of printing the solution to the Sudoku puzzles his boss previously published. Unfortunately, his boss doesn’t have those solutions, the randomly generated problems don’t have any solution, and he doesn’t even remember which is which. In despair, the assistant calls for your help.
 

Input
The first line of the input will contain the number of test cases. Each test case will consist of a 9 by 9 grid of characters, where each character will either be ‘?’ or a digit between 1 and 9 inclusively.
 

Output
For each test case, you must print back the grid to the standard input, replacing each question mark with an appropriate digit to solve the Sudoku. If a test case does not allow any solution, output ”impossible” instead of a completed grid. If a test case do allow a solution, you can assume that the solution will be unique, and that theoretically it could be reached without guessing.

Test cases are separated by “---” both in the input and in the output.
 

Sample Input
  
  
3 ??4??9??8 ?3??5??1? 7??4??2?? 3??8??1?? ?5?????9? ??6??1??2 ??8??3??1 ?2??4??5? 6??1??7?? --- ??4??9??8 ?3??5??1? 7??4??2?? 3??8??1?? ?5?????9? ??6??1??2 ??8??3??1 62??4??5? 6??1??7?? --- 3?1????76 7??9????? 2?5?3???? ?????64?1 ???2?1??? 1?25????? ????8?9?3 ?????9??4 51????7?8
 

Sample Output
  
  
264319578 839257416 715486239 372894165 451632897 986571342 548763921 127948653 693125784 --- impossible --- 391452876 764918532 285637149 953876421 678241395 142593687 426785913 837169254 519324768
 

Source


还是数独,和以前一题差不多,也是数独,链接http://blog.csdn.net/hurmishine/article/details/51333913
但这题更加容易一点了

AC代码:

#include <iostream>
#include <cstring>
using namespace std;
int a[10][10];
int sum;
typedef struct Node
{
    int x,y;
};
Node node[100];
bool flag;
bool OK(int p,int x)//在第p个位置放x
{
    for(int i=0; i<9; i++)
    {
        if(a[node[p].x][i]==x||a[i][node[p].y]==x)
            return false;
    }
    int xx=node[p].x/3*3;
    int yy=node[p].y/3*3;
    for(int i=xx; i<xx+3; i++)
        for(int j=yy; j<yy+3; j++)
            if(a[i][j]==x)
                return false;
    return true;
}
void DFS(int step)
{
    if(step==sum)
    {
        for(int i=0; i<9; i++)
        {
            for(int j=0; j<9; j++)
                cout<<a[i][j];
            cout<<endl;
        }
        flag=true;
    }
    if(flag)
        return;
    for(int i=1; i<=9; i++)
    {
        if(OK(step,i))
        {
            a[node[step].x][node[step].y]=i;
            DFS(step+1);
            a[node[step].x][node[step].y]=0;
        }
    }
}
int main()
{
    int n;
    cin>>n;
    char c,ch[5];
    sum=0;
    for(int ii=1; ii<=n; ii++)
    {
        sum=0;
        for(int i=0; i<9; i++)
        {
            for(int j=0; j<9; j++)
            {
                cin>>c;
                if(c=='?')
                {
                    a[i][j]=0;
                    node[sum].x=i;
                    node[sum].y=j;
                    sum++;
                }
                else
                    a[i][j]=c-'0';
            }
        }
        if(ii<n)
            cin>>ch;
        flag=false;
        DFS(0);
        if(!flag)
            cout<<"impossible"<<endl;
        if(ii<n)
            cout<<"---"<<endl;
    }
    return 0;
}



评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值