HDU 1022 Train Problem I (STL 栈模拟)

153 篇文章 0 订阅
16 篇文章 1 订阅

Train Problem I

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 30420    Accepted Submission(s): 11492


Problem Description
As the new term comes, the Ignatius Train Station is very busy nowadays. A lot of student want to get back to school by train(because the trains in the Ignatius Train Station is the fastest all over the world ^v^). But here comes a problem, there is only one railway where all the trains stop. So all the trains come in from one side and get out from the other side. For this problem, if train A gets into the railway first, and then train B gets into the railway before train A leaves, train A can't leave until train B leaves. The pictures below figure out the problem. Now the problem for you is, there are at most 9 trains in the station, all the trains has an ID(numbered from 1 to n), the trains get into the railway in an order O1, your task is to determine whether the trains can get out in an order O2.
 

Input
The input contains several test cases. Each test case consists of an integer, the number of trains, and two strings, the order of the trains come in:O1, and the order of the trains leave:O2. The input is terminated by the end of file. More details in the Sample Input.
 

Output
The output contains a string "No." if you can't exchange O2 to O1, or you should output a line contains "Yes.", and then output your way in exchanging the order(you should output "in" for a train getting into the railway, and "out" for a train getting out of the railway). Print a line contains "FINISH" after each test case. More details in the Sample Output.
 

Sample Input
  
  
3 123 321 3 123 312
 

Sample Output
  
  
Yes. in in in out out out FINISH No. FINISH
Hint
Hint
For the first Sample Input, we let train 1 get in, then train 2 and train 3. So now train 3 is at the top of the railway, so train 3 can leave first, then train 2 and train 1. In the second Sample input, we should let train 3 leave first, so we have to let train 1 get in, then train 2 and train 3. Now we can let train 3 leave. But after that we can't let train 1 leave before train 2, because train 2 is at the top of the railway at the moment. So we output "No.".
 

Author

Ignatius.L

原题链接:http://acm.hdu.edu.cn/showproblem.php?pid=1022


题意:或者站只有一条铁轨,问火车是否可以按前面的序列进站后是否可以按后面的序列出站.

栈模拟:

AC代码:

#include<iostream>
#include<stack>
#define maxn 100
using namespace std;
int main()
{
    stack<char>s;
    int n,i,j,k;
    bool result[maxn];//result数组用来表示结果,1表示进栈。0表示出
    char in[maxn],out[maxn];//序列1和序列2
    while(cin>>n>>in>>out)
    {
        j=0,i=0,k=1;
        s.push(in[0]);//为防止栈空,压一个进去
        result[0]=1;//记录进来了一个。
        while(i<n&&j<n)
        {
            if(!s.empty()&&s.top()==out[j])
            {
                //如果栈顶元素与序列2当前的元素相等,则弹栈,序列2集团向后移一位。
                j++;
                s.pop();
                result[k++]=0;
            }
            else
            {
                //否则从序列1中取当前元素压入栈中。
                s.push(in[++i]);
                result[k++]=1;
            }
        }
        if(i==n)//如果I==N表示栈顶元素不等于序列2当前元素,且序列1中元素都已经入过栈,判断不能得到序列2一样的答案。
            cout<<"No."<<endl;
        else
        {
            cout<<"Yes."<<endl;
            for(i=0; i<k; i++)
                if(result[i])
                    cout<<"in"<<endl;
                else
                    cout<<"out"<<endl;
        }
        cout<<"FINISH"<<endl;
    }
    return 0;
}

AC代码2:

#include <iostream>
#include <stack>
#include <cstdio>
#include <cstring>
using namespace std;
stack<int> S;
int main()
{
    int n,i,j,k;
    bool flag[10000];
    string in,out;
    while(~scanf("%d%*c",&n))
    {
        cin >> in >> out;
        i = j = k = 0;
        while(j<n+1 && i<n)
        {
            if(!S.empty() && S.top() == out[i])
            {
                i++;
                flag[k] = true;
                k++;
                S.pop();
            }
            else
            {
                S.push(in[j]);
                flag[k] = false;
                j++;
                k++;
            }
        }
        cout<<k<<endl;
        if(k!=2*n)
        {
            cout << "No." << endl;
        }
        else
        {
            cout << "Yes." << endl;
            for(i = 0; i<k; i++)
            {
                if(flag[i])
                    cout << "out" << endl;
                else
                    cout << "in" << endl;
            }
        }
        cout << "FINISH" << endl;
    }
    return 0;
}


AC代码3:C语言模拟:

# include<stdio.h>
# include<string.h>
int main()
{
    int n,i,j,k,head;
    char a[1000],b[1000],t[1000],str[1000][10];
    while(scanf("%d%s%s",&n,a,b)!=EOF)
    {
        head=i=j=k=0;
        strcpy(str[k++],"in");
        while(i<n)
        {
            t[head]=a[i];
            while(t[head]==b[j]&&b[j]!='\0'&&t[head]!='\0')
            {
                head--;
                j++;
                strcpy(str[k++],"out");
            }
            head++;
            strcpy(str[k++],"in");
            i++;
        }
        if(head==0)
        {
            printf("Yes.\n");
            for(i=0; i<k-1; i++)
                printf("%s\n",str[i]);
            printf("FINISH\n");
        }
        else
        {
            printf("No.\n");
            printf("FINISH\n");
        }

    }
    return 0;
}




  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 3
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论 3
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值