HDU 4764 Stone (巴什博弈变形)

153 篇文章 0 订阅
10 篇文章 0 订阅

Stone

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 1297    Accepted Submission(s): 916


Problem Description
Tang and Jiang are good friends. To decide whose treat it is for dinner, they are playing a game. Specifically, Tang and Jiang will alternatively write numbers (integers) on a white board. Tang writes first, then Jiang, then again Tang, etc... Moreover, assuming that the number written in the previous round is X, the next person who plays should write a number Y such that 1 <= Y - X <= k. The person who writes a number no smaller than N first will lose the game. Note that in the first round, Tang can write a number only within range [1, k] (both inclusive). You can assume that Tang and Jiang will always be playing optimally, as they are both very smart students.
 

Input
There are multiple test cases. For each test case, there will be one line of input having two integers N (0 < N <= 10^8) and k (0 < k <= 100). Input terminates when both N and k are zero.
 

Output
For each case, print the winner's name in a single line.
 

Sample Input
  
  
1 1 30 3 10 2 0 0
 

Sample Output
  
  
Jiang Tang Jiang
 

Source


题意:有一个数字 n ,两人轮流选数相加(范围为[1,k]),当某人加上所选数字时,和大于等于 n 的时候则失败.
判断谁能赢得比赛.
要想赢得比赛,报了最后一个数后和必须为 n-1,此时边=便转变为总数为n-1纳什博弈!

AC代码:

#include <iostream>
using namespace std;
int main()
{
    int n,k;
    while(cin>>n>>k)
    {
        if(n==0&&k==0)
            break;
        if((n-1)%(k+1))
            cout<<"Tang"<<endl;//1
        else
            cout<<"Jiang"<<endl;
    }
    return 0;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值