HDU 1492 The number of divisors(约数) about Humble Numbers(数论题目要知道定理呀....)

153 篇文章 0 订阅
11 篇文章 0 订阅

The number of divisors(约数) about Humble Numbers

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 3339    Accepted Submission(s): 1633


Problem Description
A number whose only prime factors are 2,3,5 or 7 is called a humble number. The sequence 1, 2, 3, 4, 5, 6, 7, 8, 9, 10, 12, 14, 15, 16, 18, 20, 21, 24, 25, 27, ... shows the first 20 humble numbers. 

Now given a humble number, please write a program to calculate the number of divisors about this humble number.For examle, 4 is a humble,and it have 3 divisors(1,2,4);12 have 6 divisors.

 

Input
The input consists of multiple test cases. Each test case consists of one humble number n,and n is in the range of 64-bits signed integer. Input is terminated by a value of zero for n.
 

Output
For each test case, output its divisor number, one line per case.
 

Sample Input
  
  
4 12 0
 

Sample Output
  
  
3 6
 

Author
lcy
 

Source


题意:求素因子(2,3,5,7)的个数,

这道题目就是一道数学题,题意大致为问某个数是否为“谦虚数”,就是满足所有的因子都是由2,3,5,7这四个质因子所组成的数据,然后问这个数有多少个因子;

解法:就是将数据拆分,统计每个素因子的个数,然后直接相乘即可先分解质因数.

数论里的结论:
如果一个数分解质因数的形式是:M = x^a * y^b * z^c * ...

则M的约数个数 = (a+1)(b+1)(c+1)...


AC代码:

/**先分解质因数
如果一个数分解质因数的形式是:
M = x^a * y^b * z^c * ...
则M的约数个数 = (a+1)(b+1)(c+1)...*/

#include <iostream>
using namespace std;
int main()
{
    __int64 n,a,b,c,d;
    while(cin>>n,n)
    {
        a=b=c=d=1;
        while(n%2==0)
        {
            a++;
            n/=2;
        }
        while(n%3==0)
        {
            b++;
            n/=3;
        }
        while(n%5==0)
        {
            c++;
            n/=5;
        }
        while(n%7==0)
        {
            d++;
            n/=7;
        }
        cout<<a*b*c*d<<endl;
    }
    return 0;
}



  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值